Plantronics Voyager Bluetooth Issue



  • I have ended up running the battery totally dead on my bluetooth twice now and both times I have had difficulty getting it to take a fresh charge.
    Plus the 1st time it happened I had a terrible time getting it to work properly when I would answer a call.
    As soon as I answered the call it would disconnect from the phone.
    I would then have to hit the bluetooth button and it would reconnect right away.

    In a last gasp I ended up using the updater make a small change to the programed settings.
    It cleared it up.

    This last time I had a very difficult time.
    It didn't matter what I tried, it just would not link for the initial charge.
    Finally it linked up and now it appears to be fully charged and functioning.

    This really concerns me though.
    I'm thinking that 1st the earpiece should turn itself off before the battery is fully discharged.
    2nd I would like it if once it got close to dying if it would give me a minute by minute countdown similar to how it tells you how many hours of use are remaining.



  • @radar696
    Only but so much of that you will get:

    Check for updates
    Turn it off when charging

    • I'm thinking that 1st the earpiece should turn itself off before the battery is fully discharged.

    Likely it is, Li-Ion hits a level and auto cuts off to prevent discharge damage.

    • 2nd I would like it if once it got close to dying if it would give me a minute by minute countdown similar to how it tells you how many hours of use are remaining

    Good luck with that - that is a firmware item and not likely to be possible



  • @gjacobse

    Thank you for your response.

    First and foremost I would have swore that I posted this as a Plantronics Legend earpiece not the Voyager as it shows in the thread title.
    I'm not really sure how that happened.

    I have had 2 other earpieces prior to this one and those were Voyagers but both have now passed on to electronic heaven.

    I'm sure that anything I ask for will mostly fall on deaf ears simply because they have moved on to newer models.

    I can say that I did end up using this earpiece once while I was running the push mower and my son on the other end of the call could not hear it.
    He was surprised when I told him the mower was running and I had to finish the lawn!
    He said what mower?
    He couldn't hear a thing except for our conversation!
    I was impressed!

    I've read how many people have their favorites from other brands but unless something drastic happened I will go back to Plantronics once this model dies.



  • I happen to have one:

    0_1504024105359_bcbb6397-8937-4f2c-a8f9-38d6b71e31a6-image.png

    I have issue with it from time to time... like now,. Turn it on it connects fine,.. go to voice dial - it disconnects (without voice notificatoin)...

    Biggest grip beyond that is that it falls out of my ear,.. regardless of which of the ear pads are in.



  • I had one for a couple months and it stopped taking a charge as well. It just died on me and was useless.



  • @gjacobse said in Plantronics Voyager Bluetooth Issue:

    I happen to have one:
    I have issue with it from time to time... like now,. Turn it on it connects fine,.. go to voice dial - it disconnects (without voice notification)...

    Biggest grip beyond that is that it falls out of my ear,.. regardless of which of the ear pads are in.
    Well I can'thelp with it falling out of your ear since I do have to press mine back into the ear from time to time.

    I can help I think with the disconnect issue though.
    Have you used the Hub program that you can download?
    It allows you to update the software and adjust the settings to your preference.

    I have used this to fix a disconnect issue.
    Just by changing the settings a small bit and then saving them to the earpiece.
    You can then go and change them back to your previous settings once you have completed the 1st step.

    I only seem to have these issues if I run the battery down to the point where it turns itself off.
    Go figure.

    Just the quick update seems to have fixed my glitch.
    I can't guarantee that it will work as well for you but give it a try.
    Plus it will help you keep the software updated to the latest level if you haven't done that yet.

    It would be nice if they would give you the option of a factory reset.
    I've felt all along that would work best for the problem I was having.

    I hope that works for you.
    When it's working properly it's hard to beat in my opinion anyway.


Log in to reply