Updating XenOrchestra to 5.11



  • Anyone tried to update to 5.11? It broke my installation, reverted to last snapshot, let me know how it goes for others...



  • @shwetkprabhat said in Xen Orchestra - Community Edition - Installing with Yarn:

    Anyone tried to update to 5.11? It broke my installation, reverted to last snapshot, let me know how it goes for others...

    Testing now.



  • @shwetkprabhat You're running on next-release aren't you?



  • @dustinb3403 Not sure I understand the question...I am running xo-server 5.10.2 and xo-web 5.10.5 on Ubuntu 16.04.2 LTS (GNU/Linux 4.4.0-87-generic x86_64)


  • Service Provider

    @shwetkprabhat said in Xen Orchestra - Community Edition - Installing with Yarn:

    @dustinb3403 Not sure I understand the question...I am running xo-server 5.10.2 and xo-web 5.10.5 on Ubuntu 16.04.2 LTS (GNU/Linux 4.4.0-87-generic x86_64)

    He means the GIT branch.



  • @scottalanmiller ah ok - I may have tried that during troubleshooting but I am sure I reverted to master, how do I check what I am using?



  • My test VM updated fine earlier today. Can you provide more details about what didn't work for you?



  • @danp I was not able to access XOC via web, the installation went alright and the service was up.



  • So if I used the

    sudo curl https://raw.githubusercontent.com/Jarli01/xenorchestra_installer/master/xo_install.sh | bash

    command to install how do I upgrade?



  • @hobbit666 To update and to enable some functionality, if you run the below you'll get the ability to import your configuration settings.

    sudo bash
    sudo curl https://raw.githubusercontent.com/Jarli01/xenorchestra_updater/master/xo-update.sh | bash -s -- -f



  • @hobbit666 More detailed instructions for updating can be found on GH -- https://github.com/Jarli01/xenorchestra_updater



  • @shwetkprabhat Strange. Did you check the logs with journalctl -u xo-server -f -n 50?



  • @danp I did not troubleshoot much, now that its confirmed that the update is working, I can play around later today.



  • @danp said in Xen Orchestra - Community Edition - Installing with Yarn:

    journalctl -u xo-server -f -n 50

    [10:44:00] Finished 'build' after 2.95 min
    Done in 215.32s.
    Updated version v5.11.0
    Restarting xo-server...
    [email protected]:~# journalctl -u xo-server -f -n 50
    -- Logs begin at Tue 2017-08-01 10:37:23 EDT. --
    Aug 01 10:44:09 xo xo-server[2045]:     at Function.Module._load (module.js:458:3)
    Aug 01 10:44:09 xo xo-server[2045]:     at Module.require (module.js:513:17)
    Aug 01 10:44:09 xo xo-server[2045]:     at require (internal/module.js:11:18)
    Aug 01 10:44:09 xo xo-server[2045]:     at Object.<anonymous> (/opt/xo-server/bin/xo-server:31:25)
    Aug 01 10:44:09 xo xo-server[2045]:     at Module._compile (module.js:569:30)
    Aug 01 10:44:09 xo xo-server[2045]:     at Object.Module._extensions..js (module.js:580:10)
    Aug 01 10:44:09 xo xo-server[2045]:     at Module.load (module.js:503:32)
    Aug 01 10:44:09 xo xo-server[2045]:     at tryModuleLoad (module.js:466:12)
    Aug 01 10:44:09 xo xo-server[2045]:     at Function.Module._load (module.js:458:3)
    Aug 01 10:44:09 xo xo-server[2045]:     at Function.Module.runMain (module.js:605:10)
    Aug 01 10:44:09 xo xo-server[2045]:     at startup (bootstrap_node.js:158:16)
    Aug 01 10:44:09 xo xo-server[2045]:     at bootstrap_node.js:575:3
    Aug 01 10:44:09 xo systemd[1]: xo-server.service: Main process exited, code=exited, status=1/FAILURE
    Aug 01 10:44:09 xo systemd[1]: xo-server.service: Unit entered failed state.
    Aug 01 10:44:09 xo systemd[1]: xo-server.service: Failed with result 'exit-code'.
    Aug 01 10:44:09 xo systemd[1]: xo-server.service: Service hold-off time over, scheduling restart.
    Aug 01 10:44:09 xo systemd[1]: Stopped XO Server.
    Aug 01 10:44:09 xo systemd[1]: Started XO Server.
    Aug 01 10:44:09 xo xo-server[2054]: module.js:487
    Aug 01 10:44:09 xo xo-server[2054]:     throw err;
    Aug 01 10:44:09 xo xo-server[2054]:     ^
    Aug 01 10:44:09 xo xo-server[2054]: Error: Cannot find module './dist'
    Aug 01 10:44:09 xo xo-server[2054]:     at Function.Module._resolveFilename (module.js:485:15)
    Aug 01 10:44:09 xo xo-server[2054]:     at Function.Module._load (module.js:437:25)
    Aug 01 10:44:09 xo xo-server[2054]:     at Module.require (module.js:513:17)
    Aug 01 10:44:09 xo xo-server[2054]:     at require (internal/module.js:11:18)
    Aug 01 10:44:09 xo xo-server[2054]:     at Object.<anonymous> (/opt/xo-server/index.js:11:18)
    Aug 01 10:44:09 xo xo-server[2054]:     at Module._compile (module.js:569:30)
    Aug 01 10:44:09 xo xo-server[2054]:     at Object.Module._extensions..js (module.js:580:10)
    Aug 01 10:44:09 xo xo-server[2054]:     at Module.load (module.js:503:32)
    Aug 01 10:44:09 xo xo-server[2054]:     at tryModuleLoad (module.js:466:12)
    Aug 01 10:44:09 xo xo-server[2054]:     at Function.Module._load (module.js:458:3)
    Aug 01 10:44:09 xo xo-server[2054]:     at Module.require (module.js:513:17)
    Aug 01 10:44:09 xo xo-server[2054]:     at require (internal/module.js:11:18)
    Aug 01 10:44:09 xo xo-server[2054]:     at Object.<anonymous> (/opt/xo-server/bin/xo-server:31:25)
    Aug 01 10:44:09 xo xo-server[2054]:     at Module._compile (module.js:569:30)
    Aug 01 10:44:09 xo xo-server[2054]:     at Object.Module._extensions..js (module.js:580:10)
    Aug 01 10:44:09 xo xo-server[2054]:     at Module.load (module.js:503:32)
    Aug 01 10:44:09 xo xo-server[2054]:     at tryModuleLoad (module.js:466:12)
    Aug 01 10:44:09 xo xo-server[2054]:     at Function.Module._load (module.js:458:3)
    Aug 01 10:44:09 xo xo-server[2054]:     at Function.Module.runMain (module.js:605:10)
    Aug 01 10:44:09 xo xo-server[2054]:     at startup (bootstrap_node.js:158:16)
    Aug 01 10:44:09 xo xo-server[2054]:     at bootstrap_node.js:575:3
    Aug 01 10:44:09 xo systemd[1]: xo-server.service: Main process exited, code=exited, status=1/FAILURE
    Aug 01 10:44:09 xo systemd[1]: xo-server.service: Unit entered failed state.
    Aug 01 10:44:09 xo systemd[1]: xo-server.service: Failed with result 'exit-code'.
    Aug 01 10:44:09 xo systemd[1]: xo-server.service: Service hold-off time over, scheduling restart.
    Aug 01 10:44:09 xo systemd[1]: Stopped XO Server.
    Aug 01 10:44:09 xo systemd[1]: xo-server.service: Start request repeated too quickly.
    Aug 01 10:44:09 xo systemd[1]: Failed to start XO Server.
    


  • @shwetkprabhat Please try

    systemctl stop xo-server.service
    followed by
    systemctl start xo-server.service
    followed by
    journalctl -u xo-server -f -n 50



  • To post code you can either put 4 blank spaces in front of each line (notepad++ is great for this) or use the ``` characters and close them with the same 3 characters.



  • @dustinb3403

    [email protected]:~$ systemctl start xo-server.service
    ==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
    Authentication is required to start 'xo-server.service'.
    Authenticating as: xoa,,, (xoa)
    Password: 
    ==== AUTHENTICATION COMPLETE ===
    [email protected]:~$ journalctl -u xo-server -f -n 50
    -- Logs begin at Tue 2017-08-01 10:37:23 EDT. --
    Aug 01 11:52:50 xo xo-server[3274]:     at Function.Module._load (module.js:458:3)
    Aug 01 11:52:50 xo xo-server[3274]:     at Module.require (module.js:513:17)
    Aug 01 11:52:50 xo xo-server[3274]:     at require (internal/module.js:11:18)
    Aug 01 11:52:50 xo xo-server[3274]:     at Object.<anonymous> (/opt/xo-server/bin/xo-server:31:25)
    Aug 01 11:52:50 xo xo-server[3274]:     at Module._compile (module.js:569:30)
    Aug 01 11:52:50 xo xo-server[3274]:     at Object.Module._extensions..js (module.js:580:10)
    Aug 01 11:52:50 xo xo-server[3274]:     at Module.load (module.js:503:32)
    Aug 01 11:52:50 xo xo-server[3274]:     at tryModuleLoad (module.js:466:12)
    Aug 01 11:52:50 xo xo-server[3274]:     at Function.Module._load (module.js:458:3)
    Aug 01 11:52:50 xo xo-server[3274]:     at Function.Module.runMain (module.js:605:10)
    Aug 01 11:52:50 xo xo-server[3274]:     at startup (bootstrap_node.js:158:16)
    Aug 01 11:52:50 xo xo-server[3274]:     at bootstrap_node.js:575:3
    Aug 01 11:52:50 xo systemd[1]: xo-server.service: Main process exited, code=exited, status=1/FAILURE
    Aug 01 11:52:50 xo systemd[1]: xo-server.service: Unit entered failed state.
    Aug 01 11:52:50 xo systemd[1]: xo-server.service: Failed with result 'exit-code'.
    Aug 01 11:52:50 xo systemd[1]: xo-server.service: Service hold-off time over, scheduling restart.
    Aug 01 11:52:50 xo systemd[1]: Stopped XO Server.
    Aug 01 11:52:50 xo systemd[1]: Started XO Server.
    Aug 01 11:52:50 xo xo-server[3283]: module.js:487
    Aug 01 11:52:50 xo xo-server[3283]:     throw err;
    Aug 01 11:52:50 xo xo-server[3283]:     ^
    Aug 01 11:52:50 xo xo-server[3283]: Error: Cannot find module './dist'
    Aug 01 11:52:50 xo xo-server[3283]:     at Function.Module._resolveFilename (module.js:485:15)
    Aug 01 11:52:50 xo xo-server[3283]:     at Function.Module._load (module.js:437:25)
    Aug 01 11:52:50 xo xo-server[3283]:     at Module.require (module.js:513:17)
    Aug 01 11:52:50 xo xo-server[3283]:     at require (internal/module.js:11:18)
    Aug 01 11:52:50 xo xo-server[3283]:     at Object.<anonymous> (/opt/xo-server/index.js:11:18)
    Aug 01 11:52:50 xo xo-server[3283]:     at Module._compile (module.js:569:30)
    Aug 01 11:52:50 xo xo-server[3283]:     at Object.Module._extensions..js (module.js:580:10)
    Aug 01 11:52:50 xo xo-server[3283]:     at Module.load (module.js:503:32)
    Aug 01 11:52:50 xo xo-server[3283]:     at tryModuleLoad (module.js:466:12)
    Aug 01 11:52:50 xo xo-server[3283]:     at Function.Module._load (module.js:458:3)
    Aug 01 11:52:50 xo xo-server[3283]:     at Module.require (module.js:513:17)
    Aug 01 11:52:50 xo xo-server[3283]:     at require (internal/module.js:11:18)
    Aug 01 11:52:50 xo xo-server[3283]:     at Object.<anonymous> (/opt/xo-server/bin/xo-server:31:25)
    Aug 01 11:52:50 xo xo-server[3283]:     at Module._compile (module.js:569:30)
    Aug 01 11:52:50 xo xo-server[3283]:     at Object.Module._extensions..js (module.js:580:10)
    Aug 01 11:52:50 xo xo-server[3283]:     at Module.load (module.js:503:32)
    Aug 01 11:52:50 xo xo-server[3283]:     at tryModuleLoad (module.js:466:12)
    Aug 01 11:52:50 xo xo-server[3283]:     at Function.Module._load (module.js:458:3)
    Aug 01 11:52:50 xo xo-server[3283]:     at Function.Module.runMain (module.js:605:10)
    Aug 01 11:52:50 xo xo-server[3283]:     at startup (bootstrap_node.js:158:16)
    Aug 01 11:52:50 xo xo-server[3283]:     at bootstrap_node.js:575:3
    Aug 01 11:52:50 xo systemd[1]: xo-server.service: Main process exited, code=exited, status=1/FAILURE
    Aug 01 11:52:50 xo systemd[1]: xo-server.service: Unit entered failed state.
    Aug 01 11:52:50 xo systemd[1]: xo-server.service: Failed with result 'exit-code'.
    Aug 01 11:52:50 xo systemd[1]: xo-server.service: Service hold-off time over, scheduling restart.
    Aug 01 11:52:50 xo systemd[1]: Stopped XO Server.
    Aug 01 11:52:50 xo systemd[1]: xo-server.service: Start request repeated too quickly.
    Aug 01 11:52:50 xo systemd[1]: Failed to start XO Server. 
    


  • Also the install logs if that helps:

    [email protected]:~$ sudo bash
    [sudo] password for xoa: 
    [email protected]:~# sudo curl https://raw.githubusercontent.com/Jarli01/xenorchestra_updater/master/xo-update.sh | bash -s -- -f
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100  2624  100  2624    0     0   3341      0 --:--:-- --:--:-- --:--:--  3338
    Stopping xo-server...
    Checking for Yarn package...
    Checking for Yarn update...
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    yarn is already the newest version (0.27.5-1).
    The following packages were automatically installed and are no longer required:
      linux-headers-4.4.0-62 linux-headers-4.4.0-62-generic linux-headers-4.4.0-72 linux-headers-4.4.0-72-generic linux-headers-4.4.0-75 linux-headers-4.4.0-75-generic linux-headers-4.4.0-78
      linux-headers-4.4.0-78-generic linux-headers-4.4.0-79 linux-headers-4.4.0-79-generic linux-headers-4.4.0-81 linux-headers-4.4.0-81-generic linux-image-4.4.0-62-generic linux-image-4.4.0-72-generic
      linux-image-4.4.0-75-generic linux-image-4.4.0-78-generic linux-image-4.4.0-79-generic linux-image-4.4.0-81-generic linux-image-extra-4.4.0-62-generic linux-image-extra-4.4.0-72-generic
      linux-image-extra-4.4.0-75-generic linux-image-extra-4.4.0-78-generic linux-image-extra-4.4.0-79-generic linux-image-extra-4.4.0-81-generic rlwrap
    Use 'sudo apt autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Checking xo-server...
    Current branch stable
    Current version v5.10.2
    10 updates available
    Updating from source...
    No local changes to save
    Updating f05117b..1ded2f8
    Fast-forward
     package.json                 |  36 ++++-----
     src/api/network.js           |   1 +
     src/api/sr.js                |  14 ++++
     src/api/vm.coffee            |   6 +-
     src/collection/redis.js      |  33 ++++----
     src/xapi/index.js            |  32 +++++---
     src/xapi/mixins/storage.js   |  43 ++++++++++
     src/xo-mixins/xen-servers.js |  17 +++-
     yarn.lock                    | 730 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++---------------------------------------------------------------------------------
     9 files changed, 506 insertions(+), 406 deletions(-)
    Clearing directories...
    Adding existing plugins to Yarn lock file...
    yarn upgrade v0.27.5
    [1/4] Resolving packages...
    error Command failed.
    Exit code: 128
    Command: git
    Arguments: pull
    Directory: /usr/local/share/.cache/yarn/v1/.tmp/9c352cb3d905b22933aca1779127b89c
    Output:
    error: Pull is not possible because you have unmerged files.
    hint: Fix them up in the work tree, and then use 'git add/rm <file>'
    hint: as appropriate to mark resolution and make a commit.
    fatal: Exiting because of an unresolved conflict.
    info Visit https://yarnpkg.com/en/docs/cli/upgrade for documentation about this command.
    Installing...
    yarn install v0.27.5
    [1/4] Resolving packages...
    [2/4] Fetching packages...
    error Command failed.
    Exit code: 128
    Command: git
    Arguments: pull
    Directory: /usr/local/share/.cache/yarn/v1/.tmp/9c352cb3d905b22933aca1779127b89c
    Output:
    error: Pull is not possible because you have unmerged files.
    hint: Fix them up in the work tree, and then use 'git add/rm <file>'
    hint: as appropriate to mark resolution and make a commit.
    fatal: Exiting because of an unresolved conflict.
    info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
    Updated version v5.11.0
    Checking xo-web...
    Current branch stable
    Current version v5.10.5
    10 updates available
    Updating from source...
    Saved working directory and index state WIP on stable: 79a8565 5.10.5
    HEAD is now at 79a8565 5.10.5
    Updating 79a8565..ec4a732
    Fast-forward
     CHANGELOG.md                                    |  15 ++++++++-
     package.json                                    |   2 +-
     src/common/action-bar.js                        |  71 ++++++++++++++++++++--------------------
     src/common/editable/index.js                    |   1 -
     src/common/form/select-plain-object.js          |   2 +-
     src/common/intl/index.js                        |   4 +++
     src/common/intl/locales/fr.js                   |   3 ++
     src/common/intl/messages.js                     |  19 +++++++----
     src/common/link.js                              |  10 ++++++
     src/common/modal.js                             |  33 +++++++------------
     src/common/react-novnc.js                       |   2 +-
     src/common/state-button.js                      |   6 +++-
     src/common/tab-button.js                        |   4 ++-
     src/common/utils.js                             |  23 +++++++++++--
     src/common/xo/index.js                          |  12 +++++++
     src/common/xo/install-xosan-pack-modal/index.js |  17 +++++-----
     src/icons.scss                                  |   8 +++++
     src/xo-app/backup/new/index.js                  | 228 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++---------------------------------------------------------------
     src/xo-app/backup/overview/index.js             |   2 +-
     src/xo-app/backup/restore/index.js              |   2 +-
     src/xo-app/home/index.js                        | 214 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++--------------------------------------------------
     src/xo-app/host/action-bar.js                   |  67 +++++++++++++++++++-------------------
     src/xo-app/host/index.js                        |   1 -
     src/xo-app/host/tab-advanced.js                 |   2 +-
     src/xo-app/host/tab-network.js                  |   6 ++--
     src/xo-app/jobs/new/index.js                    |   2 +-
     src/xo-app/logs/index.js                        |   7 ++--
     src/xo-app/menu/index.js                        |   2 +-
     src/xo-app/new-vm/index.js                      |  52 +++++++----------------------
     src/xo-app/new/sr/index.js                      |   2 +-
     src/xo-app/pool/action-bar.js                   |  52 +++++++++++++++--------------
     src/xo-app/pool/index.js                        |   1 -
     src/xo-app/pool/tab-logs.js                     |  44 +++++++++++++++++--------
     src/xo-app/self/index.js                        |   8 ++---
     src/xo-app/settings/ips/index.js                |   8 ++---
     src/xo-app/sr/action-bar.js                     |  50 ++++++++++++++--------------
     src/xo-app/sr/index.js                          |   1 -
     src/xo-app/sr/tab-advanced.js                   |  56 +++++++++++++++++++++++++++++++-
     src/xo-app/user/index.js                        |   6 ++--
     src/xo-app/vm/action-bar.js                     | 265 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++---------------------------------------------------------------------
     src/xo-app/vm/index.js                          |   1 -
     src/xo-app/vm/tab-advanced.js                   |  18 +++++-----
     src/xo-app/vm/tab-general.js                    |  12 +++----
     src/xo-app/vm/tab-network.js                    |   2 +-
     src/xo-app/xosan/index.js                       |   6 ++--
     45 files changed, 759 insertions(+), 590 deletions(-)
    Clearing directories...
    Installing...
    yarn install v0.27.5
    [1/4] Resolving packages...
    [2/4] Fetching packages...
    warning [email protected]: The platform "linux" is incompatible with this module.
    info "[email protected]" is an optional dependency and failed compatibility check. Excluding it from installation.
    [3/4] Linking dependencies...
    [4/4] Rebuilding all packages...
    success Saved lockfile.
    $ npm run build
    
    > [email protected] build /opt/xo-web
    > npm run build-indexes && NODE_ENV=production gulp build
    
    
    > [email protected] build-indexes /opt/xo-web
    > index-modules --auto src
    
    index generated src/common/themes/index.js
    index generated src/common/intl/locales/index.js
    [10:41:03] Using gulpfile /opt/xo-web/gulpfile.js
    [10:41:03] Starting 'build'...
    [10:41:03] Starting 'buildPages'...
    [10:41:03] Starting 'buildScripts'...
    [10:41:03] Starting 'buildStyles'...
    [10:41:03] Starting 'copyAssets'...
    [10:41:07] Finished 'buildPages' after 4.29 s
    [10:41:11] Finished 'buildStyles' after 8.72 s
    [10:41:12] Finished 'copyAssets' after 9.41 s
    [10:44:00] Finished 'buildScripts' after 2.95 min
    [10:44:00] Finished 'build' after 2.95 min
    Done in 215.32s.
    Updated version v5.11.0
    Restarting xo-server...
    


  • @shwetkprabhat said in Xen Orchestra - Community Edition - Installing with Yarn:

    Also the install logs if that helps:

    [email protected]:~$ sudo bash
    [sudo] password for xoa: 
    [email protected]:~# sudo curl https://raw.githubusercontent.com/Jarli01/xenorchestra_updater/master/xo-update.sh | bash -s -- -f
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100  2624  100  2624    0     0   3341      0 --:--:-- --:--:-- --:--:--  3338
    Stopping xo-server...
    Checking for Yarn package...
    Checking for Yarn update...
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    yarn is already the newest version (0.27.5-1).
    The following packages were automatically installed and are no longer required:
      linux-headers-4.4.0-62 linux-headers-4.4.0-62-generic linux-headers-4.4.0-72 linux-headers-4.4.0-72-generic linux-headers-4.4.0-75 linux-headers-4.4.0-75-generic linux-headers-4.4.0-78
      linux-headers-4.4.0-78-generic linux-headers-4.4.0-79 linux-headers-4.4.0-79-generic linux-headers-4.4.0-81 linux-headers-4.4.0-81-generic linux-image-4.4.0-62-generic linux-image-4.4.0-72-generic
      linux-image-4.4.0-75-generic linux-image-4.4.0-78-generic linux-image-4.4.0-79-generic linux-image-4.4.0-81-generic linux-image-extra-4.4.0-62-generic linux-image-extra-4.4.0-72-generic
      linux-image-extra-4.4.0-75-generic linux-image-extra-4.4.0-78-generic linux-image-extra-4.4.0-79-generic linux-image-extra-4.4.0-81-generic rlwrap
    Use 'sudo apt autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Checking xo-server...
    Current branch stable
    Current version v5.10.2
    10 updates available
    Updating from source...
    No local changes to save
    Updating f05117b..1ded2f8
    Fast-forward
     package.json                 |  36 ++++-----
     src/api/network.js           |   1 +
     src/api/sr.js                |  14 ++++
     src/api/vm.coffee            |   6 +-
     src/collection/redis.js      |  33 ++++----
     src/xapi/index.js            |  32 +++++---
     src/xapi/mixins/storage.js   |  43 ++++++++++
     src/xo-mixins/xen-servers.js |  17 +++-
     yarn.lock                    | 730 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++---------------------------------------------------------------------------------
     9 files changed, 506 insertions(+), 406 deletions(-)
    Clearing directories...
    Adding existing plugins to Yarn lock file...
    yarn upgrade v0.27.5
    [1/4] Resolving packages...
    error Command failed.
    Exit code: 128
    Command: git
    Arguments: pull
    Directory: /usr/local/share/.cache/yarn/v1/.tmp/9c352cb3d905b22933aca1779127b89c
    Output:
    error: Pull is not possible because you have unmerged files.
    hint: Fix them up in the work tree, and then use 'git add/rm <file>'
    hint: as appropriate to mark resolution and make a commit.
    fatal: Exiting because of an unresolved conflict.
    info Visit https://yarnpkg.com/en/docs/cli/upgrade for documentation about this command.
    Installing...
    yarn install v0.27.5
    [1/4] Resolving packages...
    [2/4] Fetching packages...
    error Command failed.
    Exit code: 128
    Command: git
    Arguments: pull
    Directory: /usr/local/share/.cache/yarn/v1/.tmp/9c352cb3d905b22933aca1779127b89c
    Output:
    error: Pull is not possible because you have unmerged files.
    hint: Fix them up in the work tree, and then use 'git add/rm <file>'
    hint: as appropriate to mark resolution and make a commit.
    fatal: Exiting because of an unresolved conflict.
    info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
    Updated version v5.11.0
    Checking xo-web...
    Current branch stable
    Current version v5.10.5
    10 updates available
    Updating from source...
    Saved working directory and index state WIP on stable: 79a8565 5.10.5
    HEAD is now at 79a8565 5.10.5
    Updating 79a8565..ec4a732
    Fast-forward
     CHANGELOG.md                                    |  15 ++++++++-
     package.json                                    |   2 +-
     src/common/action-bar.js                        |  71 ++++++++++++++++++++--------------------
     src/common/editable/index.js                    |   1 -
     src/common/form/select-plain-object.js          |   2 +-
     src/common/intl/index.js                        |   4 +++
     src/common/intl/locales/fr.js                   |   3 ++
     src/common/intl/messages.js                     |  19 +++++++----
     src/common/link.js                              |  10 ++++++
     src/common/modal.js                             |  33 +++++++------------
     src/common/react-novnc.js                       |   2 +-
     src/common/state-button.js                      |   6 +++-
     src/common/tab-button.js                        |   4 ++-
     src/common/utils.js                             |  23 +++++++++++--
     src/common/xo/index.js                          |  12 +++++++
     src/common/xo/install-xosan-pack-modal/index.js |  17 +++++-----
     src/icons.scss                                  |   8 +++++
     src/xo-app/backup/new/index.js                  | 228 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++---------------------------------------------------------------
     src/xo-app/backup/overview/index.js             |   2 +-
     src/xo-app/backup/restore/index.js              |   2 +-
     src/xo-app/home/index.js                        | 214 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++--------------------------------------------------
     src/xo-app/host/action-bar.js                   |  67 +++++++++++++++++++-------------------
     src/xo-app/host/index.js                        |   1 -
     src/xo-app/host/tab-advanced.js                 |   2 +-
     src/xo-app/host/tab-network.js                  |   6 ++--
     src/xo-app/jobs/new/index.js                    |   2 +-
     src/xo-app/logs/index.js                        |   7 ++--
     src/xo-app/menu/index.js                        |   2 +-
     src/xo-app/new-vm/index.js                      |  52 +++++++----------------------
     src/xo-app/new/sr/index.js                      |   2 +-
     src/xo-app/pool/action-bar.js                   |  52 +++++++++++++++--------------
     src/xo-app/pool/index.js                        |   1 -
     src/xo-app/pool/tab-logs.js                     |  44 +++++++++++++++++--------
     src/xo-app/self/index.js                        |   8 ++---
     src/xo-app/settings/ips/index.js                |   8 ++---
     src/xo-app/sr/action-bar.js                     |  50 ++++++++++++++--------------
     src/xo-app/sr/index.js                          |   1 -
     src/xo-app/sr/tab-advanced.js                   |  56 +++++++++++++++++++++++++++++++-
     src/xo-app/user/index.js                        |   6 ++--
     src/xo-app/vm/action-bar.js                     | 265 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++---------------------------------------------------------------------
     src/xo-app/vm/index.js                          |   1 -
     src/xo-app/vm/tab-advanced.js                   |  18 +++++-----
     src/xo-app/vm/tab-general.js                    |  12 +++----
     src/xo-app/vm/tab-network.js                    |   2 +-
     src/xo-app/xosan/index.js                       |   6 ++--
     45 files changed, 759 insertions(+), 590 deletions(-)
    Clearing directories...
    Installing...
    yarn install v0.27.5
    [1/4] Resolving packages...
    [2/4] Fetching packages...
    warning [email protected]: The platform "linux" is incompatible with this module.
    info "[email protected]" is an optional dependency and failed compatibility check. Excluding it from installation.
    [3/4] Linking dependencies...
    [4/4] Rebuilding all packages...
    success Saved lockfile.
    $ npm run build
    
    > [email protected] build /opt/xo-web
    > npm run build-indexes && NODE_ENV=production gulp build
    
    
    > [email protected] build-indexes /opt/xo-web
    > index-modules --auto src
    
    index generated src/common/themes/index.js
    index generated src/common/intl/locales/index.js
    [10:41:03] Using gulpfile /opt/xo-web/gulpfile.js
    [10:41:03] Starting 'build'...
    [10:41:03] Starting 'buildPages'...
    [10:41:03] Starting 'buildScripts'...
    [10:41:03] Starting 'buildStyles'...
    [10:41:03] Starting 'copyAssets'...
    [10:41:07] Finished 'buildPages' after 4.29 s
    [10:41:11] Finished 'buildStyles' after 8.72 s
    [10:41:12] Finished 'copyAssets' after 9.41 s
    [10:44:00] Finished 'buildScripts' after 2.95 min
    [10:44:00] Finished 'build' after 2.95 min
    Done in 215.32s.
    Updated version v5.11.0
    Restarting xo-server...
    

    This part looks to be correct, what happens if you go to the IP address of this system?



  • Something failed during the install....

    @shwetkprabhat said in Xen Orchestra - Community Edition - Installing with Yarn:

    yarn upgrade v0.27.5
    [1/4] Resolving packages...
    error Command failed.
    Exit code: 128
    Command: git
    Arguments: pull
    Directory: /usr/local/share/.cache/yarn/v1/.tmp/9c352cb3d905b22933aca1779127b89c
    Output:
    error: Pull is not possible because you have unmerged files.
    hint: Fix them up in the work tree, and then use 'git add/rm <file>'
    hint: as appropriate to mark resolution and make a commit.
    fatal: Exiting because of an unresolved conflict.
    info Visit https://yarnpkg.com/en/docs/cli/upgrade for documentation about this command.



  • @danp ok - how to figure this out?



  • @shwetkprabhat First step would be to remove the node_modules subdirectory from both xo-server and xo-web directories and then try rebuilding --

     rm -rf node_modules
     yarn
    


  • @danp same result :(



  • @shwetkprabhat Look for the file yarn-error.log and post its contents if it exists.



  • @danp said in Xen Orchestra - Community Edition - Installing with Yarn:

    yarn-error.log

    Arguments: 
      /usr/local/bin/node /usr/share/yarn/bin/yarn.js
    
    PATH: 
      /home/xoa/bin:/home/xoa/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
    
    Yarn version: 
      0.27.5
    
    Node version: 
      8.0.0
    
    Platform: 
      linux x64
    
    npm manifest: 
      No manifest
    
    yarn manifest: 
      No manifest
    
    Lockfile: 
      No lockfile
    
    Trace: 
      Error: EACCES: permission denied, mkdir '/home/xoa/.config/yarn/global'
    


  • @shwetkprabhat This was in the xo-server directory? With a modification date of today?



  • Also, were you running as superuser when you reissued the yarn command?



  • @danp It was in home directory with todays modify date.

    yarn gave error so I did sudo yarn and it showed success.



  • @shwetkprabhat So is XO working now? FYI, you'll need to issue sudo bash before the yarn command.



  • @danp no not working, I meant the yarn command was successful but XOC still not starting



Looks like your connection to MangoLassi was lost, please wait while we try to reconnect.