O365 Group SendAs Strangeness



  • Hi All...

    I've got a bit of an odd one. I set up a new Office 365 Group (not distribution list).

    I granted my account the "SendAs" permission, and I know that it is working... kind of.

    If I do a new Email, and just click From -> Other Email, and type in my email in...

    0_1493234028741_upload-fe8fa68d-12aa-4cab-90c4-48631d803a5c

    And then send the message, I'll immediately get a bounce message with a "you don't have permissions for that".

    If I go through the From -> Other Email -> From -> Global Address Book (not offline address book) and then find the email I am looking for, it works fine, and then adds the email address to the other addresses drop down list.

    If I go back to do a new message using the link put in the other addresses list, then it bombs again.

    Anybody seen this before?

    Edit: I am using Outlook 2013 for this.
    My account is an owner, member, and in the "SendAs" settings for the group.



  • When did you make the change? The permissions take an not insignificant amount of time to propagate.



  • @coliver said in O365 Group SendAs Strangeness:

    When did you make the change? The permissions take an not insignificant amount of time to propagate.

    I created the group, and then made the change ~ an hour ago.



  • Guess I should have just been at least a little bit patient with it. The permissions finally updated over night... Go figure.


  • Service Provider

    User error.



  • @JaredBusch said in O365 Group SendAs Strangeness:

    User error.

    Purdy much. But I still blame Microsoft.

    I found out there were some issues with folks doing stuff via the web interface and powershell that involved Distirbution Lists or O365 group permissions for 3 days this week.



  • @dafyre said in O365 Group SendAs Strangeness:

    Guess I should have just been at least a little bit patient with it. The permissions finally updated over night... Go figure.

    Yep... Permissions can take a stupid long time to propagate.



  • @coliver said in O365 Group SendAs Strangeness:

    @dafyre said in O365 Group SendAs Strangeness:

    Guess I should have just been at least a little bit patient with it. The permissions finally updated over night... Go figure.

    Yep... Permissions can take a stupid long time to propagate.

    There was some kind of O365 issue that was causing them to be slow this time. Normally when i do this, things happen in minutes, not hours.



Looks like your connection to MangoLassi was lost, please wait while we try to reconnect.