XenServer 6.5 to 7.1 using Rolling Pool Upgrade and NFS



  • I'm attempting to upgrade a XS 6.5 server I'm running (standalone host) to 7.1 using the "Rolling Pool Upgrade" feature in XenCenter and am running into an issue.

    I have the installation media copied to an NFS share on a Fedora box at my desk, and the NFS export is known to be good.

    I upgraded to XenCenter 7.1.

    When I stepped through the Rolling Pool Upgrade dialog box initially, it asked to install update RPU002 at the Prechecks stage. This appeared to work without issue. Even though it didn't prompt, I rebooted the host anyway since it's not a critical host (this is my test for when I do the upgrade in production).

    However, when I specify the location of the network install files, it complains about it being an "Invalid URL to installer files".

    I did some research, and I believe this to be my issue: https://discussions.citrix.com/topic/378305-cannot-perform-rolling-pool-upgrade-of-xenserver-7-invalid-url-to-installer-files/

    The link above is a thread on the Citrix forums about RPU002 being a fix so that XS sees the installation media properly, however said fix does not installing properly. There are instructions on how to unpack the .xsupdate file and install the offending RPM by hand. This seems to fix the issue for the folks in that thread.

    However, when I unpack RPU002.xsupdate grabbed from "C:\Program Files (x86)\Citrix\XenCenter", the files do not match what is shown in the Citrix thread. The thread above says I should have the following:

    total 240
    drwxr-xr-x 2 root root 126 May 6 11:04 ./
    drwxrwxrwt. 14 root root 45056 May 27 11:27 ../
    -rw-r--r-- 1 root root 102 May 6 11:04 CONTENTS
    -rwxr-xr-x 1 root root 5659 May 6 11:04 install.sh*
    -rw-r--r-- 1 root root 16302 May 6 11:04 upgrade-plugin-2.1.1-xs2435.noarch.rpm
    -rw-r--r-- 1 root root 141581 May 6 11:04 xcp-python-libs-1.9.0-159.noarch.rpm

    But I get this:

    total 184K
    drwxrwxrwt 7 root root 4.0K Mar 21 13:36 ..
    drwxr-xr-x 2 root root 4.0K Jan 5 04:37 .
    -rw-r--r-- 1 root root 102 Jan 5 04:37 CONTENTS
    -rw-r--r-- 1 root root 18K Jan 5 04:37 host-upgrade-plugin-1.1.0-1.noarch.rpm
    -rwxr-xr-x 1 root root 5.6K Jan 5 04:37 install.sh
    -rw-r--r-- 1 root root 139K Jan 5 04:37 xcp-python-libs-2.0.0-161.noarch.rpm

    Any ideas? I suspect I have the wrong RPU002.xsupdate somehow. Maybe I should try a clean install of XenCenter (just occurred to me now)?



  • Could it simply be that there is a newer version of the fix for XS 7.1? The prior discussion was for 7.0.



  • @Danp I suppose that is possible. Hmm...



  • @anthonyh Reason is that when you upgraded XenCenter to 7.1 it has a different RPU002.xsupdate than what the poster had on the thread you mention. The poster noted the following on the thread: "you can find it in "c:\Program Files\Citrix\XenCenter". These 2 hotfixes (RPU0001 and RPU0002) are a part of XenCenter 7.0 install."



  • Well, I unpacked all three of the updates found in the XenCenter directory. Here's what they look like:

    ./RPU001:
    total 1.1M
    drwxr-xr-x 2 root root 4.0K Mar 27 11:19 .
    drwxr-xr-x 7 root root 4.0K Mar 27 11:23 ..
    -rw-r--r-- 1 root root  150 Mar 27 11:19 CONTENTS
    -rw-r--r-- 1 root root  18K Mar 27 11:19 host-upgrade-plugin-1.1.0-1.noarch.rpm
    -rwxr-xr-x 1 root root 5.6K Mar 27 11:19 install.sh
    -rw-r--r-- 1 root root 837K Mar 27 11:19 iproute-2.6.35.1-1.xs1138.i386.rpm
    -rw-r--r-- 1 root root 139K Mar 27 11:19 xcp-python-libs-2.0.0-161.noarch.rpm
    
    ./RPU002:
    total 184K
    drwxr-xr-x 2 root root 4.0K Mar 27 11:21 .
    drwxr-xr-x 7 root root 4.0K Mar 27 11:23 ..
    -rw-r--r-- 1 root root  102 Mar 27 11:21 CONTENTS
    -rw-r--r-- 1 root root  18K Mar 27 11:21 host-upgrade-plugin-1.1.0-1.noarch.rpm
    -rwxr-xr-x 1 root root 5.6K Mar 27 11:21 install.sh
    -rw-r--r-- 1 root root 139K Mar 27 11:21 xcp-python-libs-2.0.0-161.noarch.rpm
    
    ./RPU003:
    total 40K
    drwxr-xr-x 2 root root 4.0K Mar 27 11:23 .
    drwxr-xr-x 7 root root 4.0K Mar 27 11:23 ..
    -rw-r--r-- 1 root root   52 Mar 27 11:22 CONTENTS
    -rw-r--r-- 1 root root  17K Mar 27 11:22 host-upgrade-plugin-1.1.0-1.noarch.rpm
    -rwxr-xr-x 1 root root 5.6K Mar 27 11:22 install.sh
    

    I checked to see which of these packages are currently installed:

    [[email protected] ~]# rpm -qa | grep -e host-upgrade-plugin -e iproute -e xcp-python-libs
    iproute-3.6.0-1.xs1393
    xcp-python-libs-2.0.0-161
    host-upgrade-plugin-1.1.0-1
    [[email protected] ~]#
    

    The server is running a newer version of iproute, but otherwise equal versions of xcp-python-libs and host-upgrade-plugin. I can't imagine the issue would be with the iproute package?

    Hmm...



  • I installed XenCenter 7.0.1 on another box and unpacked the updates that accompany it:

    ./RPU001:
    total 1.0M
    drwxr-xr-x 2 root root 4.0K Mar 27 13:06 .
    drwxr-xr-x 7 root root 4.0K Mar 27 13:07 ..
    -rw-r--r-- 1 root root  150 Mar 27 13:06 CONTENTS
    -rwxr-xr-x 1 root root 5.6K Mar 27 13:06 install.sh
    -rw-r--r-- 1 root root 837K Mar 27 13:06 iproute-2.6.35.1-1.xs1138.i386.rpm
    -rw-r--r-- 1 root root  16K Mar 27 13:06 upgrade-plugin-2.1.1-xs2435.noarch.rpm
    -rw-r--r-- 1 root root 139K Mar 27 13:06 xcp-python-libs-1.9.0-159.noarch.rpm
    
    ./RPU002:
    total 180K
    drwxr-xr-x 2 root root 4.0K Mar 27 13:06 .
    drwxr-xr-x 7 root root 4.0K Mar 27 13:07 ..
    -rw-r--r-- 1 root root  102 Mar 27 13:06 CONTENTS
    -rwxr-xr-x 1 root root 5.6K Mar 27 13:06 install.sh
    -rw-r--r-- 1 root root  16K Mar 27 13:06 upgrade-plugin-2.1.1-xs2435.noarch.rpm
    -rw-r--r-- 1 root root 139K Mar 27 13:06 xcp-python-libs-1.9.0-159.noarch.rpm
    

    The only differences I can see is the followign:

    • XenCenter 7.0.1 comes with "upgrade-plugin-2.1.1-xs2435.noarch.rpm" and "xcp-python-libs-1.9.0-159.noarch.rpm"
    • XenCenter 7.1.0 comes with "host-upgrade-plugin-1.1.0-1.noarch.rpm" and "xcp-python-libs-2.0.0-161.noarch.rpm".

    Just for the heck of it I'm going to manually install "upgrade-plugin-2.1.1-xs2435.noarch.rpm" and see what happens.



  • Looks like I'll need to uninstall "host-upgrade-plugin-1.1.0-1.noarch" first. :-D

    [[email protected] RPU001]# rpm -Uvh upgrade-plugin-2.1.1-xs2435.noarch.rpm 
    Preparing...                ########################################### [100%]    
       	file /etc/xapi.d/plugins/prepare_host_upgrade.py from install of upgrade-plugin-2.1.1-xs2435.noarch conflicts with file from package host-upgrade-plugin-1.1.0-1.noarch
    	file /etc/xapi.d/plugins/prepare_host_upgrade.pyc from install of upgrade-plugin-2.1.1-xs2435.noarch conflicts with file from package host-upgrade-plugin-1.1.0-1.noarch
    	file /etc/xapi.d/plugins/prepare_host_upgrade.pyo from install of upgrade-plugin-2.1.1-xs2435.noarch conflicts with file from package host-upgrade-plugin-1.1.0-1.noarch
    [[email protected] RPU001]#


  • Ok, I uninstalled "host-upgrade-plugin-1.1.0-1.noarch" and installed "upgrade-plugin-2.1.1-xs2435.noarch.rpm" and it was still a no go. So, I decided to check the install media again. I thought, that cp -Rf also copied hidden files? Looks like I was missing ".treeinfo" at the root of the installer media. Copying the file over from the ISO gives me a nice pretty green check-mark when testing the location of the network install files. Yay!

    So, perhaps, the next time I upgrade a host XenCenter will apply the appropriate RPU update(s) and the install path will be seen as good. :-D



  • @anthonyh awesome, looks as if you are all ser now.



  • @Eltolargo I think so. Waiting for the install to finish on my test host now...

    0_1490647868640_upload-5efbfb58-bbbb-430f-8e91-a1259c458b96



  • Woot!

    0_1490648834783_upload-215b82f2-0732-469b-a8af-23a583d53806



  • @anthonyh Awesome! Great job!


Log in to reply
 

Looks like your connection to MangoLassi was lost, please wait while we try to reconnect.