Using Vultr for FreePBX 13



  • Obviously, you will need to create an account and fund it. I leave that exercise to you.

    Click the big + to create a new server.
    0_1474901749624_upload-bae97806-5bd8-46bd-b482-4bf5b0533144

    Choose a location relative to your primary users and your SIP provider.
    0_1474902059997_upload-f3de9efc-81ca-4634-bd13-eb7affcd20c2

    Choose Custom ISO and select the FreePBX ISO you previously uploaded.
    0_1474902138672_upload-63fda5c8-de30-497c-9298-09fb64b19a33

    Select the smallest server size, it is more than enough for hundreds of extensions.
    0_1474902306148_upload-d8bb4df4-8013-4929-a4b3-e80ac45bdc0f

    Leave the additional features alone and give your server a host name. If you want a space in the server label you have to manually add it. No space in your hostname please.
    0_1474902400631_upload-1f97b51b-74ac-4138-9bdf-fbac6bbed20d

    Click deploy and wait for the system to tell you it is ready.
    0_1474902657756_upload-b1b50077-5f84-438b-b6f0-428d191951e0

    Connect to the console, and select the second option Full Install -- No RAID
    0_1474900435977_upload-d9670f14-03cc-458b-8c2d-9f15a79ddee2

    Part of the FreePBX 13 Setup Guide



  • @JaredBusch Is there a reason to choose "No RAID" other than the obvious reason of the face there isn't an RAID present on the Vultr instance?



  • @EddieJennings said in Using Vultr for FreePBX 13:

    @JaredBusch Is there a reason to choose "No RAID" other than the obvious reason of the face there isn't an RAID present on the Vultr instance?

    Basically you always choose it. It's effectively the only option. The ONLY time you'd not choose it is if you were deploying on physical which is a never, ever thing.



  • I like Vultr's stat page.
    Here is the network usage of a PBX with ~80 extensions (all pjsip, if that matters) and 15 simultaneous calls at peak.

    0_1502251700302_e90dfe59-8805-4c4b-b76e-449d02aa884b-image.png

    Here is the network graph from FreePBX itself.
    0_1502251855611_6a516f64-4c8e-41c4-a605-12ece1bedcea-image.png



  • This has been super helpful! I started out with the CyberLynk hosting which was nice, but a lot costlier. It included some commercial modules but Vultr is cheaper enough to pay for them fairly quickly. I do have one annoying issue I haven't solved though. I set this up from my home office and I can reach the web gui from there, but can't get to it from my office network. For the life of me I can't find anyplace to allow/block access to the gui. Any ideas?



  • @u2communications said in Using Vultr for FreePBX 13:

    This has been super helpful! I started out with the CyberLynk hosting which was nice, but a lot costlier. It included some commercial modules but Vultr is cheaper enough to pay for them fairly quickly. I do have one annoying issue I haven't solved though. I set this up from my home office and I can reach the web gui from there, but can't get to it from my office network. For the life of me I can't find anyplace to allow/block access to the gui. Any ideas?

    In the FreePBX firewall.
    https://mangolassi.it/topic/12322/configure-the-freepbx-smart-firewall/2



  • @jaredbusch, Awesome as usual Jared. Though mine looks very different - no zones button. I just went to the Networks tab and added my WAN subnet as Trusted (Excluded from Firewall) and I'm all set. I can't believe I didn't see that!



  • @u2communications said in Using Vultr for FreePBX 13:

    @jaredbusch, Awesome as usual Jared. Though mine looks very different - no zones button. I just went to the Networks tab and added my WAN subnet as Trusted (Excluded from Firewall) and I'm all set. I can't believe I didn't see that!

    The delayed load of the pictures probably caused the scroll to not be in the right place. Post 2 of that thread shows the current FreePBX 14 view.

    But it sounds like you found the right setting.



  • @JaredBusch Hi, Jared. I appreciate this information on Vultr. I've got a hosted freePBX system up and running on Vultr now. Have you had trouble with tftp in a hosted environment? For the life of me I can't get it working. Works on a local install. Does not work on a hosted install. I've checked too many things to list here, but was wondering if you (or anybody else) has gotten it to work in a hosted environment. If yes, then it's back to lab for me. Thanks.



  • @prabbide said in Using Vultr for FreePBX 13:

    @JaredBusch Hi, Jared. I appreciate this information on Vultr. I've got a hosted freePBX system up and running on Vultr now. Have you had trouble with tftp in a hosted environment? For the life of me I can't get it working. Works on a local install. Does not work on a hosted install. I've checked too many things to list here, but was wondering if you (or anybody else) has gotten it to work in a hosted environment. If yes, then it's back to lab for me. Thanks.

    I would never use tftp over the internet. There is no security in it at all.

    That said, assuming your system is setup properly it will work just fine. It is simply a setting in your DHCP server to tell the phone where to go.

    You need to have the service open in the FreePBX firewall and make sure it is allowed out of your router.



  • @JaredBusch

    LET FREEEEDOM RING BABY



  • @JaredBusch said in Using Vultr for FreePBX 13:

    I would never use tftp over the internet. There is no security in it at all.

    I was out at breakfast when I made the reply. Let me clarify.

    Using tftp to pull configs over the internet have no possible method to encrypt the information in transit.

    So if somewhere along the way, your traffic is sniffed (most likely is softphone on a mobile device on a public hotspot), the data inside the phone config files is 100% plain text. This is a super bad thing because these config files contain the SIP credentials for the device in question.

    Once someone has your valid credentials, they have access to make calls on your dime.

    Using http is no different. I recommend only using https on the public internet.

    Now, you can mitigate by only allowing known IP addresses through the firewall. By doing that, there is no way for someone to get to your data form everywhere around the world.

    To be clear this, is only about keeping the configuration files secret because they contain sensitive information. SIP registration is a totally different issue. That process has no need for encryption. The SIP protocol negotiates a nonce witht he PBX when it begins the registration process for an extension. The device never sends the registration password in the clear.



  • @JaredBusch said in Using Vultr for FreePBX 13:

    I recommend only using https on the public internet.

    Now even tough I say that, there are potential problems with this on some devices.

    /me glares at Yealink T4XG series devices

    FreePBX's default Let's Encrypt certificate process on FreePBX 14 creates a Let's Encrypt certificate that Yealink T4XG series phones refuse to talk to. The exact same phone talking to FreePBX 13 with a LE cert generated by FreePBX works just fine.

    So you have to decide to get some other certificate or use take the risk of using http for you device communication. I continue to hpe the Yealink will release a firmware update for this, but it is unlikely as that series of phones are no longer sold. They do not seem to consider them EoL yet, but they were replaced by the T4XS line.



  • @JaredBusch Yep. tftp is not optimal for security reasons. Nevertheless, it actually does not seem to work in a hosted freepbx environment and I can't figure out (yet) why. I've turned off the IPFW (yes, I know...this is a test box). I've set the xinet service tftp to verbose logging and tracked the activity. The tftp client successfully talks with the server, requests files, but eventually times out with no data transmitted). I've set my local firewall wide open for the IP address. I'm able to tftp locally from another known good remote tftp server. I've checked the freepbx forums (there are similar complaints about tftp, but those are not on a hosted server and tend to be user error). Was hoping you had run across this issue and made it work (even though it's not recommended). Thanks for your feedback.



  • @JaredBusch

    Hi,

    Did you also notice that v14 is super slow compared to v13 ?



  • @Emad-R said in Using Vultr for FreePBX 13:

    @JaredBusch

    Hi,

    Did you also notice that v14 is super slow compared to v13 ?

    It assuredly is not. I use it daily. I do not use 13 daily any more, but when I did have active clients on both versions, I never had noticeably different speeds in the GUI.



  • @JaredBusch said in Using Vultr for FreePBX 13:

    @Emad-R said in Using Vultr for FreePBX 13:

    @JaredBusch

    Hi,

    Did you also notice that v14 is super slow compared to v13 ?

    It assuredly is not. I use it daily. I do not use 13 daily any more, but when I did have active clients on both versions, I never had noticeably different speeds in the GUI.

    We still have one client that won't upgrade (they make lots of excuses) and we don't notice a difference either.



  • @prabbide said in Using Vultr for FreePBX 13:

    @JaredBusch Yep. tftp is not optimal for security reasons. Nevertheless, it actually does not seem to work in a hosted freepbx environment and I can't figure out (yet) why. I've turned off the IPFW (yes, I know...this is a test box). I've set the xinet service tftp to verbose logging and tracked the activity. The tftp client successfully talks with the server, requests files, but eventually times out with no data transmitted). I've set my local firewall wide open for the IP address. I'm able to tftp locally from another known good remote tftp server. I've checked the freepbx forums (there are similar complaints about tftp, but those are not on a hosted server and tend to be user error). Was hoping you had run across this issue and made it work (even though it's not recommended). Thanks for your feedback.

    You sure Vultr firewall isn't blocking TFTP?



  • @Dashrender said in Using Vultr for FreePBX 13:

    @prabbide said in Using Vultr for FreePBX 13:

    @JaredBusch Yep. tftp is not optimal for security reasons. Nevertheless, it actually does not seem to work in a hosted freepbx environment and I can't figure out (yet) why. I've turned off the IPFW (yes, I know...this is a test box). I've set the xinet service tftp to verbose logging and tracked the activity. The tftp client successfully talks with the server, requests files, but eventually times out with no data transmitted). I've set my local firewall wide open for the IP address. I'm able to tftp locally from another known good remote tftp server. I've checked the freepbx forums (there are similar complaints about tftp, but those are not on a hosted server and tend to be user error). Was hoping you had run across this issue and made it work (even though it's not recommended). Thanks for your feedback.

    You sure Vultr firewall isn't blocking TFTP?

    Vultr doesn't have a firewall unless you make one.
    I mean it is possible they could. Let me test.



  • @JaredBusch said in Using Vultr for FreePBX 13:

    @Dashrender said in Using Vultr for FreePBX 13:

    @prabbide said in Using Vultr for FreePBX 13:

    @JaredBusch Yep. tftp is not optimal for security reasons. Nevertheless, it actually does not seem to work in a hosted freepbx environment and I can't figure out (yet) why. I've turned off the IPFW (yes, I know...this is a test box). I've set the xinet service tftp to verbose logging and tracked the activity. The tftp client successfully talks with the server, requests files, but eventually times out with no data transmitted). I've set my local firewall wide open for the IP address. I'm able to tftp locally from another known good remote tftp server. I've checked the freepbx forums (there are similar complaints about tftp, but those are not on a hosted server and tend to be user error). Was hoping you had run across this issue and made it work (even though it's not recommended). Thanks for your feedback.

    You sure Vultr firewall isn't blocking TFTP?

    Vultr doesn't have a firewall unless you make one.
    I mean it is possible they could. Let me test.

    Lots of people put one in by default and don't even think about it.



  • My setup with FreePBX 14 on Vultr.

    1. There is no firewall on Vultr blocking anything.
    2. My home network is marked trusted in the FreePBX responsive firewall.
    3. The tftp protocal is allowed in the FreePBX firewall to local connections.

    I can connect to from my desktop with tftp but I cannot download anything.
    690a6734-0e8c-48f8-b0a9-bede9d66fac1-image.png



  • @JaredBusch said in Using Vultr for FreePBX 13:

    My setup with FreePBX 14 on Vultr.

    1. There is no firewall on Vultr blocking anything.
    2. My home network is marked trusted in the FreePBX responsive firewall.
    3. The tftp protocal is allowed in the FreePBX firewall to local connections.

    I can connect to from my desktop with tftp but I cannot download anything.
    690a6734-0e8c-48f8-b0a9-bede9d66fac1-image.png

    right - so why not?



  • @Dashrender said in Using Vultr for FreePBX 13:

    @JaredBusch said in Using Vultr for FreePBX 13:

    My setup with FreePBX 14 on Vultr.

    1. There is no firewall on Vultr blocking anything.
    2. My home network is marked trusted in the FreePBX responsive firewall.
    3. The tftp protocal is allowed in the FreePBX firewall to local connections.

    I can connect to from my desktop with tftp but I cannot download anything.
    690a6734-0e8c-48f8-b0a9-bede9d66fac1-image.png

    right - so why not?

    Don't know and don't honestly care. As I said before. Don't use TFTP on the public internet.



  • I wonder if TFTP default bindings are LAN only.



  • @scottalanmiller said in Using Vultr for FreePBX 13:

    I wonder if TFTP default bindings are LAN only.

    /shrug

    It let me connect.

    Note: it also does not work on my ZeroTier address.
    7e94208d-7834-48bf-a1f1-01c9c253907b-image.png



  • @JaredBusch said in Using Vultr for FreePBX 13:

    @scottalanmiller said in Using Vultr for FreePBX 13:

    I wonder if TFTP default bindings are LAN only.

    /shrug

    It let me connect.

    Note: it also does not work on my ZeroTier address.
    7e94208d-7834-48bf-a1f1-01c9c253907b-image.png

    Now that is weird!



  • @JaredBusch said in Using Vultr for FreePBX 13:

    My setup with FreePBX 14 on Vultr.

    1. There is no firewall on Vultr blocking anything.
    2. My home network is marked trusted in the FreePBX responsive firewall.
    3. The tftp protocal is allowed in the FreePBX firewall to local connections.

    I can connect to from my desktop with tftp but I cannot download anything.
    690a6734-0e8c-48f8-b0a9-bede9d66fac1-image.png

    Exactly my problem. But I concluded the same thing. Who cares? I do have a small reason to care, but I've got a workaround and moved on to other topics. Thanks for your 2 cents! Glad it wasn't just me.