SaltStack Installer Fails on Ubuntu 16.10 Yakkety Missing GnuPG-Curl



  • Salt's installer uses GnuPG-Curl as part of the installation script and this package has been removed from Ubuntu after 16.04. So current Ubuntu and, we presume, into the future will not have this and this breaks Salt's "universal" installer, aka Bootstrap. So we have to resort to the PPA method instead. Installation is just as easy:

    sudo add-apt-repository ppa:saltstack/salt
    sudo apt-get install salt-minion
    

    Look in your Salt Master, you should have already connected 🙂



  • If you ran the Bootstrap script, this is what you would have gotten as the error:

    Fetched 1,035 kB in 1s (959 kB/s)
    Reading package lists...
    Reading package lists...
    Building dependency tree...
    Reading state information...
    ca-certificates is already the newest version (20160104ubuntu1).
    apt-transport-https is already the newest version (1.3.2ubuntu0.1).
    apt-transport-https set to manually installed.
    0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.
    Reading package lists...
    Building dependency tree...
    Reading state information...
    E: Unable to locate package gnupg-curl
     * ERROR: Failed to run install_ubuntu_stable_deps()!!!