Wazo 16.16 Software Selection Installation Error



  • Installation moves along fine but seems to want some package decisions that are not yet made:

    0_1481597995308_Screenshot from 2016-12-12 21-59-18.png

    If you go back and re-run the step, it just keeps bringing you back to here.



  • Switched to a different installation web source, tried the text installer and still the same error.



  • From where did you get this screenshot? I don't know it.



  • @quintana said in Wazo 16.16 Software Selection Installation Error:

    From where did you get this screenshot? I don't know it.

    From the Wazo install ISO.



  • I downloaded the Wazo 16.16 installed ISO from the site. Mounted it on the VM and fired it up. It kicks off a Debian 8 installer and steps you through the process, failing at the software selection stage.



  • @scottalanmiller ok, what are you using? kvm, virtualbox ...? Everything can be automatic, so if you have an error it's because our installer don't like something. Have you tried with a debian 8 iso? It's possible to install wazo directly from a debian fresh install.



  • @quintana said in Wazo 16.16 Software Selection Installation Error:

    @scottalanmiller ok, what are you using? kvm, virtualbox ...? Everything can be automatic, so if you have an error it's because our installer don't like something. Have you tried with a debian 8 iso? It's possible to install wazo directly from a debian fresh install.

    It was the Wazo ISO on Vultr, so KVM under the hood. Nothing Wazo branded came up, it just appeared as a Debian 8 installer.

    Do you have Debian 8 installation instructions? I can try that out easily enough.



  • @scottalanmiller have you tried without the graphical installer from debian?



  • For vultr there is a tutorial from nerdvittles. http://nerdvittles.com/?page_id=18907
    But instead of using incrediblepbx script you can use directly the wazo script.

    http://documentation.wazo.community/en/stable/installation/installsystem.html#installing-from-a-minimal-debian-installation



  • @quintana said in Wazo 16.16 Software Selection Installation Error:

    @scottalanmiller have you tried without the graphical installer from debian?

    Yes, tried graphical and text, both did the same thing.



  • @scottalanmiller ok i don't know vultr but looks like it works with the nerdvittles tutorial.



  • @quintana said in Wazo 16.16 Software Selection Installation Error:

    @scottalanmiller ok i don't know vultr but looks like it works with the nerdvittles tutorial.

    Just ran that and it failed.



  • Here is the output of the end of the build script:

    Warning: The home dir /run/uuidd you specified can't be accessed: No such file or directory
    Adding system user `uuidd' (UID 112) ...
    Adding new user `uuidd' (UID 112) with group `uuidd' ...
    Not creating home directory `/run/uuidd'.
    Setting up python3-stevedore (0.14.1-1) ...
    Setting up xivo-agentd (16.16~20161205.122318.76839a1) ...
    Adding system user xivo-agentd
    Adding user xivo-agentd to group www-data
    Setting up xivo-amid (16.16~20161205.122841.d0b9ba5) ...
    Adding system user xivo-amid
    Adding user xivo-amid to group www-data
    Setting up python-crypto (2.6.1-5+b2) ...
    Setting up python-twisted-conch (1:14.0.2-3) ...
    Setting up python-twisted-mail (14.0.2-3) ...
    Setting up python-twisted-lore (14.0.2-3) ...
    Setting up python-twisted-names (14.0.2-3) ...
    Setting up python-twisted-news (14.0.2-3) ...
    Setting up python-twisted-runner (14.0.2-3) ...
    Setting up python-twisted-words (14.0.2-3) ...
    Setting up python-twisted (14.0.2-3) ...
    Setting up xivo-confgend (1:16.16~20161207.184322.378bba5) ...
    Adding system user xivo-confgend
    Setting up xivo-ctid (1:16.16~20161205.125909.d42aacc) ...
    Adding system user xivo-ctid
    Adding user xivo-ctid to group www-data
    Setting up xivo-dird (16.16~20161205.133200.2b6656a) ...
    Traceback (most recent call last):
      File "/usr/bin/xivo-dird-init-db", line 75, in <module>
        main()
      File "/usr/bin/xivo-dird-init-db", line 66, in main
        db_helper.create_db(cursor, args.db, args.owner)
      File "/usr/lib/python2.7/dist-packages/xivo/db_helper.py", line 38, in create_db
        cursor.execute(sql)
    psycopg2.DataError: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)
    HINT:  Use the same encoding as in the template database, or use template0 as template.
    
    dpkg: error processing package xivo-dird (--configure):
     subprocess installed post-installation script returned error exit status 1
    Setting up ethtool (1:3.16-1) ...
    Setting up hdparm (9.43-2) ...
    update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
    Setting up libcrypt-ssleay-perl (0.58-1+b2) ...
    Setting up libcurses-perl (1.32-1) ...
    Setting up libdate-manip-perl (6.47-1) ...
    Setting up libnet-ip-perl (1.26-1) ...
    Setting up libnet-netmask-perl (1.9021-1) ...
    Setting up libnet-telnet-perl (3.04-1) ...
    Setting up libterm-readkey-perl (2.32-1+b1) ...
    Setting up libencode-locale-perl (1.03-1) ...
    Setting up libtimedate-perl (2.3000-2) ...
    Setting up libhttp-date-perl (6.02-1) ...
    Setting up libfile-listing-perl (6.04-1) ...
    Setting up liburi-perl (1.64-1) ...
    Setting up libhtml-tagset-perl (3.20-2) ...
    Setting up libhtml-parser-perl (3.71-1+b3) ...
    Setting up libhtml-tree-perl (5.03-1) ...
    Setting up libio-html-perl (1.001-1) ...
    Setting up liblwp-mediatypes-perl (6.02-1) ...
    Setting up libhttp-message-perl (6.06-1) ...
    Setting up libhttp-cookies-perl (6.01-1) ...
    Setting up libhttp-negotiate-perl (6.00-2) ...
    Setting up libnet-ssleay-perl (1.65-1+deb8u1) ...
    Setting up libio-socket-ssl-perl (2.002-2+deb8u1) ...
    Setting up libsocket6-perl (0.25-1+b1) ...
    Setting up libio-socket-inet6-perl (2.72-1) ...
    Setting up libnet-http-perl (6.07-1) ...
    Setting up libwww-robotrules-perl (6.01-1) ...
    Setting up fonts-dejavu-extra (2.34-1) ...
    Setting up fonts-dejavu (2.34-1) ...
    Setting up libfile-copy-recursive-perl (0.38-1) ...
    Setting up libhtml-template-perl (2.95-1) ...
    Setting up liblog-log4perl-perl (1.44-1) ...
    Setting up libdbi1:amd64 (0.9.0-4) ...
    Setting up librrd4 (1.4.8-1.2) ...
    Setting up librrds-perl (1.4.8-1.2) ...
    Setting up liblist-moreutils-perl (0.33-2+b1) ...
    Setting up munin-common (2.0.25-1) ...
    Setting up rrdtool (1.4.8-1.2) ...
    Setting up munin (2.0.25-1) ...
    Setting up libio-multiplex-perl (1.13-1) ...
    Setting up libnet-cidr-perl (0.17-1) ...
    Setting up libnet-server-perl (2.008-1) ...
    Setting up munin-plugins-core (2.0.25-1) ...
    Setting up munin-node (2.0.25-1) ...
    Initializing plugins..done.
    Restarting munin-node..Setting up smartmontools (6.3+svn4002-2+b2) ...
    update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
    Setting up xivo-nginx (16.16~20161129.051452.cd7197e) ...
    Setting up xivo-provd (16.16~20161130.164458.d5e276c) ...
    Adding system user xivo-provd
    Setting up aptitude-common (0.6.11-1) ...
    Setting up libxapian22 (1.2.19-1+deb8u1) ...
    Setting up aptitude (0.6.11-1+b1) ...
    update-alternatives: using /usr/bin/aptitude-curses to provide /usr/bin/aptitude (aptitude) in auto mode
    Setting up mutt (1.5.23-3) ...
    update-alternatives: using /usr/bin/mutt-org to provide /usr/bin/mutt (mutt) in auto mode
    Setting up asterisk-sounds-main (8:14.2.1-1~wazo3) ...
    Setting up consul (0.7.1~xivo2) ...
    Adding system user consul
    Adding user consul to group www-data
    Setting up ieee-data (20150531.1~deb8u1) ...
    Setting up isc-dhcp-server (4.3.1-6+deb8u2) ...
    Generating /etc/default/isc-dhcp-server...
    Job for isc-dhcp-server.service failed. See 'systemctl status isc-dhcp-server.service' and 'journalctl -xn' for details.
    invoke-rc.d: initscript isc-dhcp-server, action "start" failed.
    Setting up libid3tag0 (0.15.1b-11) ...
    Setting up libsox-fmt-alsa:amd64 (14.4.1-5) ...
    Setting up libsox-fmt-base:amd64 (14.4.1-5) ...
    Setting up libtiff-tools (4.0.3-12.3+deb8u1) ...
    Setting up madplay (0.15.2b-8) ...
    Setting up python-billiard (3.3.0.20-1~xivo5) ...
    Setting up python-dateutil (2.2-2) ...
    Setting up python-setuptools (5.5.1-1) ...
    Setting up python-mailer (0.7-1) ...
    Setting up python-memcache (1.53+2014.06.08.git.918e88c496-1) ...
    Setting up python-pyparsing (2.0.3+dfsg1-1) ...
    Setting up python-celery (3.1.18-1~xivo7) ...
    Setting up python-dumbnet (1.12-6) ...
    Setting up python-flask-httpauth (2.2.1-1) ...
    Setting up python-m2crypto (0.21.1-3) ...
    Setting up python-netaddr (0.7.12-2) ...
    Setting up python3-pkg-resources (5.5.1-1) ...
    Setting up python3-asynqp (0.4-1~xivo3) ...
    Setting up python3-ply (3.4-5) ...
    Setting up python3-pycparser (2.10+dfsg-3) ...
    Setting up python3-cffi (0.8.6-1) ...
    Setting up python3-chardet (2.3.0-1) ...
    Setting up python3-six (1.8.0-1) ...
    Setting up python3-cryptography (0.6.1-1) ...
    Setting up python3-openssl (0.14-1) ...
    Setting up python3-psycopg2 (2.5.4+dfsg-1) ...
    Setting up python3-urllib3 (1.9.1-3) ...
    Setting up python3-requests (2.4.3-6) ...
    Setting up python3-websockets (3.0-1~xivo6) ...
    Setting up python3-yaml (3.11-2) ...
    Setting up rsync (3.1.1-3) ...
    Setting up sox (14.4.1-5) ...
    Setting up sudo (1.8.10p3-1+deb8u3) ...
    Setting up asterisk-sounds-wav-en-us (1:16.16~20161207.131829.3d0aa99) ...
    Setting up asterisk-sounds-wav-fr-fr (1:16.16~20161207.131829.3d0aa99) ...
    Setting up python-websocket (0.37.0-1~xivo1) ...
    Setting up python-swaggerpy (0.2.1-1~xivo8) ...
    Setting up python-asterisk-ari (0.2.2) ...
    Setting up python-iso8601 (0.1.10-1) ...
    Setting up python-magic (1:5.22+15-2+deb8u2) ...
    Setting up python-threadpool (1.2.7-1~xivo2) ...
    Setting up python-wsaccel (0.6.2-1~xivo2) ...
    Setting up python3-consul (0.6.0-1~xivo2) ...
    Setting up vlan (1.9-3.2) ...
    Setting up xivo-agentd-cli (16.16~20161129.135018.3614a50) ...
    Setting up xivo-agid (16.16~20161207.193031.bd9948c) ...
    Adding system user xivo-agid
    Adding user xivo-agid to group www-data
    Adding user xivo-agid to group asterisk
    Setting up xivo-amid-client (16.16~20161129.131755.2ffec0f) ...
    Setting up xivo-auth (16.16~20161205.125819.c731dd5) ...
    Adding system user xivo-auth
    Adding user xivo-auth to group www-data
    Job for xivo-auth.service failed. See 'systemctl status xivo-auth.service' and 'journalctl -xn' for details.
    invoke-rc.d: initscript xivo-auth, action "start" failed.
    dpkg: error processing package xivo-auth (--configure):
     subprocess installed post-installation script returned error exit status 1
    Setting up xivo-lib-rest-client-python3 (16.16~20161128.204804.787cd21) ...
    Setting up xivo-auth-client-python3 (16.16~20161129.115632.13089a8) ...
    Setting up xivo-auth-keys (16.16~20161128.205426.04df087) ...
    Setting up xivo-backup (16.16~20161129.050315.a8c08eb) ...
    Setting up xivo-call-logs (1:16.16~20161128.204847.50aede2) ...
    Adding system user xivo-call-logs
    Setting up xivo-manage-db (16.16~20161207.163545.eee4cb9) ...
    Traceback (most recent call last):
      File "/usr/bin/xivo-init-db", line 5, in <module>
        main()
      File "/usr/lib/python2.7/dist-packages/xivo_db/bin/init_db.py", line 61, in main
        _init_db()
      File "/usr/lib/python2.7/dist-packages/xivo_db/bin/init_db.py", line 47, in _init_db
        postgres.init_db()
      File "/usr/lib/python2.7/dist-packages/xivo_db/postgres.py", line 38, in decorator
        res = f(*args, **kwargs)
      File "/usr/lib/python2.7/dist-packages/xivo_db/postgres.py", line 66, in init_db
        db_helper.create_db(cursor, db_name, db_user)
      File "/usr/lib/python2.7/dist-packages/xivo/db_helper.py", line 38, in create_db
        cursor.execute(sql)
    psycopg2.DataError: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)
    HINT:  Use the same encoding as in the template database, or use template0 as template.
    
    dpkg: error processing package xivo-manage-db (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of xivo-libconfd:
     xivo-libconfd depends on xivo-manage-db (>> 16.01); however:
      Package xivo-manage-db is not configured yet.
    
    dpkg: error processing package xivo-libconfd (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of xivo-confd:
     xivo-confd depends on xivo-libconfd (>= 16.16~20161207.201539.156aa39); however:
      Package xivo-libconfd is not configured yet.
    
    dpkg: error processing package xivo-confd (--configure):
     dependency problems - leaving unconfigured
    Setting up xivo-confgend-client (16.16~20161129.052750.07a108f) ...
    Setting up xivo-ctid-ng (16.16~20161205.125141.326dc6e) ...
    Setting up xivo-dird-phoned (16.16~20161129.180900.db1ff69) ...
    Setting up xivo-dxtora (16.16~20161129.050027.6472627) ...
    Adding system user xivo-dxtora
    Setting up xivo-dxtorc (16.16~20161129.051257.07940a7) ...
    Setting up xivo-keyring (16.16~20161210.175417.db342a2) ...
    Setting up xivo-libsccp (16.16~20161129.062803.3488a00) ...
    Setting up xivo-provd-cli (16.16~20161129.135738.192384b) ...
    Setting up xivo-purge-db (16.16~20161129.180512.92db5d7) ...
    Setting up xivo-res-freeze-check (16.16~20161129.051530.e7485b4) ...
    Setting up xivo-service (16.16~20161205.205625.280bc8d) ...
    Setting up xivo-sounds-en-us (1:16.16~20161207.131829.3d0aa99) ...
    Setting up xivo-sounds-fr-fr (1:16.16~20161207.131829.3d0aa99) ...
    Setting up xivo-stat (16.16~20161128.204644.81e05f3) ...
    Setting up xivo-swagger-doc (16.16~20161205.120311.e7e4433) ...
    Setting up xivo-sync (16.16~20161129.052836.bc056e3) ...
    Setting up xivo-sysconfd (1:16.16~20161207.161512.70112ec) ...
    Setting up xivo-upgrade (16.16~20161209.184107.74d3ee8) ...
    Setting up xivo-lib-python-python3 (16.16~20161129.135652.d50f719) ...
    Setting up xivo-websocketd (16.16~20161129.171340.1169cbd) ...
    Adding system user xivo-websocketd
    Adding user xivo-websocketd to group www-data
    dpkg: dependency problems prevent configuration of xivo-base:
     xivo-base depends on xivo-auth; however:
      Package xivo-auth is not configured yet.
     xivo-base depends on xivo-confd; however:
      Package xivo-confd is not configured yet.
     xivo-base depends on xivo-dird; however:
      Package xivo-dird is not configured yet.
     xivo-base depends on xivo-manage-db; however:
      Package xivo-manage-db is not configured yet.
    
    dpkg: error processing package xivo-base (--configure):
     dependency problems - leaving unconfigured
    Setting up liblwp-protocol-https-perl (6.06-2) ...
    Setting up libwww-perl (6.08-1) ...
    Setting up xivo-monitoring (16.16~20161129.062722.69a24ae) ...
    Processing triggers for libc-bin (2.19-18+deb8u6) ...
    Processing triggers for systemd (215-17+deb8u5) ...
    Processing triggers for python-support (1.0.15) ...
    Processing triggers for xivo-nginx (16.16~20161129.051452.cd7197e) ...
    Errors were encountered while processing:
     xivo-dird
     xivo-auth
     xivo-manage-db
     xivo-libconfd
     xivo-confd
     xivo-base
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following extra packages will be installed:
      libonig2 libperl4-corelibs-perl libqdbm14 lsof molly-guard php-amqplib php5-cgi php5-cli php5-common php5-curl php5-gd php5-json php5-ldap php5-pgsql psmisc screen
      spawn-fcgi xivo-web-interface
    Suggested packages:
      php-pear php5-user-cache iselect screenie byobu
    Recommended packages:
      php5-readline
    The following NEW packages will be installed:
      libonig2 libperl4-corelibs-perl libqdbm14 lsof molly-guard php-amqplib php5-cgi php5-cli php5-common php5-curl php5-gd php5-json php5-ldap php5-pgsql psmisc screen
      spawn-fcgi xivo xivo-web-interface
    0 upgraded, 19 newly installed, 0 to remove and 0 not upgraded.
    6 not fully installed or removed.
    Need to get 0 B/10.2 MB of archives.
    After this operation, 43.7 MB of additional disk space will be used.
    Selecting previously unselected package libonig2:amd64.
    (Reading database ... 44109 files and directories currently installed.)
    Preparing to unpack .../libonig2_5.9.5-3.2_amd64.deb ...
    Unpacking libonig2:amd64 (5.9.5-3.2) ...
    Selecting previously unselected package psmisc.
    Preparing to unpack .../psmisc_22.21-2_amd64.deb ...
    Unpacking psmisc (22.21-2) ...
    Selecting previously unselected package libperl4-corelibs-perl.
    Preparing to unpack .../libperl4-corelibs-perl_0.003-1_all.deb ...
    Unpacking libperl4-corelibs-perl (0.003-1) ...
    Selecting previously unselected package lsof.
    Preparing to unpack .../lsof_4.86+dfsg-1_amd64.deb ...
    Unpacking lsof (4.86+dfsg-1) ...
    Selecting previously unselected package php5-common.
    Preparing to unpack .../php5-common_5.6.28+dfsg-0+deb8u1_amd64.deb ...
    Unpacking php5-common (5.6.28+dfsg-0+deb8u1) ...
    Selecting previously unselected package php-amqplib.
    Preparing to unpack .../php-amqplib_2.4.1-1_all.deb ...
    Unpacking php-amqplib (2.4.1-1) ...
    Selecting previously unselected package libqdbm14.
    Preparing to unpack .../libqdbm14_1.8.78-5+b1_amd64.deb ...
    Unpacking libqdbm14 (1.8.78-5+b1) ...
    Selecting previously unselected package php5-json.
    Preparing to unpack .../php5-json_1.3.6-1_amd64.deb ...
    Unpacking php5-json (1.3.6-1) ...
    Selecting previously unselected package php5-cli.
    Preparing to unpack .../php5-cli_5.6.28+dfsg-0+deb8u1_amd64.deb ...
    Unpacking php5-cli (5.6.28+dfsg-0+deb8u1) ...
    Selecting previously unselected package php5-cgi.
    Preparing to unpack .../php5-cgi_5.6.28+dfsg-0+deb8u1_amd64.deb ...
    Unpacking php5-cgi (5.6.28+dfsg-0+deb8u1) ...
    Selecting previously unselected package php5-curl.
    Preparing to unpack .../php5-curl_5.6.28+dfsg-0+deb8u1_amd64.deb ...
    Unpacking php5-curl (5.6.28+dfsg-0+deb8u1) ...
    Selecting previously unselected package php5-gd.
    Preparing to unpack .../php5-gd_5.6.28+dfsg-0+deb8u1_amd64.deb ...
    Unpacking php5-gd (5.6.28+dfsg-0+deb8u1) ...
    Selecting previously unselected package php5-ldap.
    Preparing to unpack .../php5-ldap_5.6.28+dfsg-0+deb8u1_amd64.deb ...
    Unpacking php5-ldap (5.6.28+dfsg-0+deb8u1) ...
    Selecting previously unselected package php5-pgsql.
    Preparing to unpack .../php5-pgsql_5.6.28+dfsg-0+deb8u1_amd64.deb ...
    Unpacking php5-pgsql (5.6.28+dfsg-0+deb8u1) ...
    Selecting previously unselected package spawn-fcgi.
    Preparing to unpack .../spawn-fcgi_1.6.4-1_amd64.deb ...
    Unpacking spawn-fcgi (1.6.4-1) ...
    Selecting previously unselected package xivo-web-interface.
    Preparing to unpack .../xivo-web-interface_16.16~20161208.213846.6240de7_all.deb ...
    Unpacking xivo-web-interface (16.16~20161208.213846.6240de7) ...
    Selecting previously unselected package screen.
    Preparing to unpack .../screen_4.2.1-3+deb8u1_amd64.deb ...
    Unpacking screen (4.2.1-3+deb8u1) ...
    Selecting previously unselected package molly-guard.
    Preparing to unpack .../molly-guard_0.4.5-1.1_all.deb ...
    Unpacking molly-guard (0.4.5-1.1) ...
    Selecting previously unselected package xivo.
    Preparing to unpack .../xivo_14%3a16.16~20161205.204232.4772219_all.deb ...
    Unpacking xivo (14:16.16~20161205.204232.4772219) ...
    Processing triggers for man-db (2.7.0.2-5) ...
    Processing triggers for xivo-nginx (16.16~20161129.051452.cd7197e) ...
    Processing triggers for systemd (215-17+deb8u5) ...
    Setting up xivo-dird (16.16~20161205.133200.2b6656a) ...
    Traceback (most recent call last):
      File "/usr/bin/xivo-dird-init-db", line 75, in <module>
        main()
      File "/usr/bin/xivo-dird-init-db", line 66, in main
        db_helper.create_db(cursor, args.db, args.owner)
      File "/usr/lib/python2.7/dist-packages/xivo/db_helper.py", line 38, in create_db
        cursor.execute(sql)
    psycopg2.DataError: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)
    HINT:  Use the same encoding as in the template database, or use template0 as template.
    
    dpkg: error processing package xivo-dird (--configure):
     subprocess installed post-installation script returned error exit status 1
    Setting up xivo-auth (16.16~20161205.125819.c731dd5) ...
    usermod: no changes
    Job for xivo-auth.service failed. See 'systemctl status xivo-auth.service' and 'journalctl -xn' for details.
    invoke-rc.d: initscript xivo-auth, action "start" failed.
    dpkg: error processing package xivo-auth (--configure):
     subprocess installed post-installation script returned error exit status 1
    Setting up xivo-manage-db (16.16~20161207.163545.eee4cb9) ...
    Traceback (most recent call last):
      File "/usr/bin/xivo-init-db", line 5, in <module>
        main()
      File "/usr/lib/python2.7/dist-packages/xivo_db/bin/init_db.py", line 61, in main
        _init_db()
      File "/usr/lib/python2.7/dist-packages/xivo_db/bin/init_db.py", line 47, in _init_db
        postgres.init_db()
      File "/usr/lib/python2.7/dist-packages/xivo_db/postgres.py", line 38, in decorator
        res = f(*args, **kwargs)
      File "/usr/lib/python2.7/dist-packages/xivo_db/postgres.py", line 66, in init_db
        db_helper.create_db(cursor, db_name, db_user)
      File "/usr/lib/python2.7/dist-packages/xivo/db_helper.py", line 38, in create_db
        cursor.execute(sql)
    psycopg2.DataError: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)
    HINT:  Use the same encoding as in the template database, or use template0 as template.
    
    dpkg: error processing package xivo-manage-db (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of xivo-libconfd:
     xivo-libconfd depends on xivo-manage-db (>> 16.01); however:
      Package xivo-manage-db is not configured yet.
    
    dpkg: error processing package xivo-libconfd (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of xivo-confd:
     xivo-confd depends on xivo-libconfd (>= 16.16~20161207.201539.156aa39); however:
      Package xivo-libconfd is not configured yet.
    
    dpkg: error processing package xivo-confd (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of xivo-base:
     xivo-base depends on xivo-auth; however:
      Package xivo-auth is not configured yet.
     xivo-base depends on xivo-confd; however:
      Package xivo-confd is not configured yet.
     xivo-base depends on xivo-dird; however:
      Package xivo-dird is not configured yet.
     xivo-base depends on xivo-manage-db; however:
      Package xivo-manage-db is not configured yet.
    
    dpkg: error processing package xivo-base (--configure):
     dependency problems - leaving unconfigured
    Setting up libonig2:amd64 (5.9.5-3.2) ...
    Setting up psmisc (22.21-2) ...
    Setting up libperl4-corelibs-perl (0.003-1) ...
    Setting up lsof (4.86+dfsg-1) ...
    Setting up php5-common (5.6.28+dfsg-0+deb8u1) ...
    
    Creating config file /etc/php5/mods-available/pdo.ini with new version
    php5_invoke: Enable module pdo for cgi SAPI
    php5_invoke: Enable module pdo for cli SAPI
    
    Creating config file /etc/php5/mods-available/opcache.ini with new version
    php5_invoke: Enable module opcache for cgi SAPI
    php5_invoke: Enable module opcache for cli SAPI
    Setting up php-amqplib (2.4.1-1) ...
    Setting up libqdbm14 (1.8.78-5+b1) ...
    Setting up php5-json (1.3.6-1) ...
    php5_invoke: Enable module json for cgi SAPI
    php5_invoke: Enable module json for cli SAPI
    Setting up php5-cli (5.6.28+dfsg-0+deb8u1) ...
    update-alternatives: using /usr/bin/php5 to provide /usr/bin/php (php) in auto mode
    update-alternatives: using /usr/bin/phar5 to provide /usr/bin/phar (phar) in auto mode
    
    Creating config file /etc/php5/cli/php.ini with new version
    Setting up php5-cgi (5.6.28+dfsg-0+deb8u1) ...
    update-alternatives: using /usr/bin/php5-cgi to provide /usr/bin/php-cgi (php-cgi) in auto mode
    update-alternatives: using /usr/lib/cgi-bin/php5 to provide /usr/lib/cgi-bin/php (php-cgi-bin) in auto mode
    
    Creating config file /etc/php5/cgi/php.ini with new version
    Setting up php5-curl (5.6.28+dfsg-0+deb8u1) ...
    
    Creating config file /etc/php5/mods-available/curl.ini with new version
    php5_invoke: Enable module curl for cgi SAPI
    php5_invoke: Enable module curl for cli SAPI
    Setting up php5-gd (5.6.28+dfsg-0+deb8u1) ...
    
    Creating config file /etc/php5/mods-available/gd.ini with new version
    php5_invoke: Enable module gd for cgi SAPI
    php5_invoke: Enable module gd for cli SAPI
    Setting up php5-ldap (5.6.28+dfsg-0+deb8u1) ...
    
    Creating config file /etc/php5/mods-available/ldap.ini with new version
    php5_invoke: Enable module ldap for cgi SAPI
    php5_invoke: Enable module ldap for cli SAPI
    Setting up php5-pgsql (5.6.28+dfsg-0+deb8u1) ...
    
    Creating config file /etc/php5/mods-available/pgsql.ini with new version
    php5_invoke: Enable module pgsql for cgi SAPI
    php5_invoke: Enable module pgsql for cli SAPI
    
    Creating config file /etc/php5/mods-available/pdo_pgsql.ini with new version
    php5_invoke: Enable module pdo_pgsql for cgi SAPI
    php5_invoke: Enable module pdo_pgsql for cli SAPI
    Setting up spawn-fcgi (1.6.4-1) ...
    Setting up xivo-web-interface (16.16~20161208.213846.6240de7) ...
    Setting up screen (4.2.1-3+deb8u1) ...
    Setting up molly-guard (0.4.5-1.1) ...
    dpkg: dependency problems prevent configuration of xivo:
     xivo depends on xivo-base (= 14:16.16~20161205.204232.4772219); however:
      Package xivo-base is not configured yet.
    
    dpkg: error processing package xivo (--configure):
     dependency problems - leaving unconfigured
    Processing triggers for libc-bin (2.19-18+deb8u6) ...
    Processing triggers for xivo-nginx (16.16~20161129.051452.cd7197e) ...
    Processing triggers for systemd (215-17+deb8u5) ...
    Errors were encountered while processing:
     xivo-dird
     xivo-auth
     xivo-manage-db
     xivo-libconfd
     xivo-confd
     xivo-base
     xivo
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Closing port 5060.
    Waiting for services to stop successfully...
    Waiting for services to start successfully...
    	starting rabbitmq-server ... OK
    	starting consul ... OK
    	starting [email protected] ... OK
    	starting nginx ... OK
    	starting dahdi ... OK
    	starting xivo-sysconfd ... OK
    	starting xivo-confgend ... OK
    	starting xivo-confd ...Job for xivo-confd.service failed. See 'systemctl status xivo-confd.service' and 'journalctl -xn' for details.
     NOK
    Opening port 5060.
    [email protected]:/tmp# systemctl status xivo-confd.service
    ā— xivo-confd.service - xivo-confd server
       Loaded: loaded (/lib/systemd/system/xivo-confd.service; disabled)
       Active: failed (Result: exit-code) since Tue 2016-12-13 22:15:03 UTC; 53s ago
      Process: 26178 ExecStart=/usr/bin/xivo-confd (code=exited, status=1/FAILURE)
      Process: 26177 ExecStartPre=/usr/bin/install -d -o www-data -g www-data /var/run/xivo-confd (code=exited, status=0/SUCCESS)
    
    Dec 13 22:15:01 vch-lnx-wazo systemd[1]: Starting xivo-confd server...
    Dec 13 22:15:03 vch-lnx-wazo xivo-confd[26178]: Could not read config file /etc/xivo-confd/config.yml: [Errno 2] No such file or directory: '/etc/xivo-confd/config.yml'
    Dec 13 22:15:03 vch-lnx-wazo systemd[1]: xivo-confd.service: control process exited, code=exited status=1
    Dec 13 22:15:03 vch-lnx-wazo systemd[1]: Failed to start xivo-confd server.
    Dec 13 22:15:03 vch-lnx-wazo systemd[1]: Unit xivo-confd.service entered failed state.
    


  • Loads of build errors, as you can see.



  • Looks like an encoding problem. Your VM is not UTF8 and the database need to be UTF8.

    psycopg2.DataError: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)
    HINT: Use the same encoding as in the template database, or use template0 as template.



  • @quintana said in Wazo 16.16 Software Selection Installation Error:

    Looks like an encoding problem. Your VM is not UTF8 and the database need to be UTF8.

    psycopg2.DataError: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)
    HINT: Use the same encoding as in the template database, or use template0 as template.

    Can the script be adapted to handle that? This is a default Debian 8 image, if it is failing it's a broader issue.



  • Firing up the ISO on Scale now to see how it is handled there.



  • @scottalanmiller I need to check! be back



  • @scottalanmiller said in Wazo 16.16 Software Selection Installation Error:

    @quintana said in Wazo 16.16 Software Selection Installation Error:

    Looks like an encoding problem. Your VM is not UTF8 and the database need to be UTF8.

    psycopg2.DataError: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)
    HINT: Use the same encoding as in the template database, or use template0 as template.

    Can the script be adapted to handle that? This is a default Debian 8 image, if it is failing it's a broader issue.

    What locale did you pick on install?
    0_1481668086614_upload-0d9d0e57-dc22-48e2-bce3-0c84acd8de3d



  • @quintana said in Wazo 16.16 Software Selection Installation Error:

    @scottalanmiller I need to check! be back

    Okay, I'm getting the test done on Scale in the meantime.



  • @JaredBusch said in Wazo 16.16 Software Selection Installation Error:

    @scottalanmiller said in Wazo 16.16 Software Selection Installation Error:

    @quintana said in Wazo 16.16 Software Selection Installation Error:

    Looks like an encoding problem. Your VM is not UTF8 and the database need to be UTF8.

    psycopg2.DataError: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)
    HINT: Use the same encoding as in the template database, or use template0 as template.

    Can the script be adapted to handle that? This is a default Debian 8 image, if it is failing it's a broader issue.

    What locale did you pick on install?
    0_1481668086614_upload-0d9d0e57-dc22-48e2-bce3-0c84acd8de3d

    Default, let me run it again and verify.



  • @scottalanmiller said in Wazo 16.16 Software Selection Installation Error:

    @JaredBusch said in Wazo 16.16 Software Selection Installation Error:

    @scottalanmiller said in Wazo 16.16 Software Selection Installation Error:

    @quintana said in Wazo 16.16 Software Selection Installation Error:

    Looks like an encoding problem. Your VM is not UTF8 and the database need to be UTF8.

    psycopg2.DataError: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)
    HINT: Use the same encoding as in the template database, or use template0 as template.

    Can the script be adapted to handle that? This is a default Debian 8 image, if it is failing it's a broader issue.

    What locale did you pick on install?
    0_1481668086614_upload-0d9d0e57-dc22-48e2-bce3-0c84acd8de3d

    Default, let me run it again and verify.

    I just hit enter all the way through myself. installing on my Hyper-V server. waiting for it to finish.



  • @JaredBusch said in Wazo 16.16 Software Selection Installation Error:

    @scottalanmiller said in Wazo 16.16 Software Selection Installation Error:

    @JaredBusch said in Wazo 16.16 Software Selection Installation Error:

    @scottalanmiller said in Wazo 16.16 Software Selection Installation Error:

    @quintana said in Wazo 16.16 Software Selection Installation Error:

    Looks like an encoding problem. Your VM is not UTF8 and the database need to be UTF8.

    psycopg2.DataError: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)
    HINT: Use the same encoding as in the template database, or use template0 as template.

    Can the script be adapted to handle that? This is a default Debian 8 image, if it is failing it's a broader issue.

    What locale did you pick on install?
    0_1481668086614_upload-0d9d0e57-dc22-48e2-bce3-0c84acd8de3d

    Default, let me run it again and verify.

    I just hit enter all the way through myself. installing on my Hyper-V server. waiting for it to finish.

    Appears to have worked on Scale. Something about the ISO on Vultr makes it not even attempt the install.



  • @JaredBusch said in Wazo 16.16 Software Selection Installation Error:

    @scottalanmiller said in Wazo 16.16 Software Selection Installation Error:

    @JaredBusch said in Wazo 16.16 Software Selection Installation Error:

    @scottalanmiller said in Wazo 16.16 Software Selection Installation Error:

    @quintana said in Wazo 16.16 Software Selection Installation Error:

    Looks like an encoding problem. Your VM is not UTF8 and the database need to be UTF8.

    psycopg2.DataError: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)
    HINT: Use the same encoding as in the template database, or use template0 as template.

    Can the script be adapted to handle that? This is a default Debian 8 image, if it is failing it's a broader issue.

    What locale did you pick on install?
    0_1481668086614_upload-0d9d0e57-dc22-48e2-bce3-0c84acd8de3d

    Default, let me run it again and verify.

    I just hit enter all the way through myself. installing on my Hyper-V server. waiting for it to finish.

    0_1481668381687_2016-12-13 16_23_14-BUNDYHV02 - ScreenConnect - Connected.png

    0_1481668393616_2016-12-13 16_23_31-BUNDYHV02 - ScreenConnect - Connected.png

    0_1481668405567_2016-12-13 16_23_41-BUNDYHV02 - ScreenConnect - Connected.png

    0_1481668418080_2016-12-13 16_31_28-BUNDYHV02 - ScreenConnect - Connected.png



  • Vultr doesn't give you options like that as you go, I have to check it from the OS.



  • Here is the build script I am working from on Debian 8:

    #!/bin/bash
    
    dd if=/dev/zero of=/swapfile bs=1024 count=1024k
    chown root:root /swapfile
    chmod 0600 /swapfile
    mkswap /swapfile
    swapon /swapfile
    echo "/swapfile swap swap defaults 0 0">>/etc/fstab
    sysctl vm.swappiness=10
    echo vm.swappiness=10>>/etc/sysctl.conf
    free -h
    cat /proc/sys/vm/swappiness
    
    apt-get -y install cloud-init
    wget http://mirror.wazo.community/fai/xivo-migration/wazo_install.sh
    chmod +x wazo_install.sh
    ./wazo_install.sh
    


  • Worked on Scale, I'm at the Wazo interface.



  • Here is the setting that failed on Vultr:

    [email protected]:/tmp# env | grep LANG
    LANG=en_US.UTF-8
    


  • @scottalanmiller said in Wazo 16.16 Software Selection Installation Error:

    Vultr doesn't give you options like that as you go, I have to check it from the OS.

    If you upload the ISO, sure they do. you have console access same as any other virtualization platform. Well I have for every other system I have tested there at least. Granted none of them were debian based.



  • @JaredBusch said in Wazo 16.16 Software Selection Installation Error:

    @scottalanmiller said in Wazo 16.16 Software Selection Installation Error:

    Vultr doesn't give you options like that as you go, I have to check it from the OS.

    If you upload the ISO, sure they do. you have console access same as any other virtualization platform. Well I have for every other system I have tested there at least. Granted none of them were debian based.

    If I do a Debian 8 ISO install rather than using Vultr's Debian 8, yes.


Log in to reply