Specific Landline from PRI Line to Specific Inbound Route



  • Dears,
    I am working on Elastix 2.5 and have PRI Line plugged into E1 Interface and everything works fine , but now i need to route specific Line from that PRI to specific Extension through inbound route " i need the syntax that should i write in the DID Number Section in the inbound route "

    any advice ?
    Thanks.



  • You create a new inbound route in the field says DID specify your phone number that you want to be caught by the route and then specify the destination like normal



  • @JaredBusch i already did this but not working with me.



  • @AlyRagab said in Specific Landline from PRI Line to Specific Inbound Route:

    @JaredBusch i already did this but not working with me.

    Then you did it wrong, most likely you did or did not include the DID number in the correct format.

    Either look in the Asterisk log or monitor the Asterisk command line interface.

    Look for how the DID is listed.

    The fastest thing is to grep the Asterisk log IMO.
    Open a SSH session to your Elastix PBX and type grep FROM_DID /var/log/asterisk/full.

    You will see results like this (real numbers obfuscated). These are two calls to different DID.

    [Dec  6 16:28:51] VERBOSE[22042][C-00001efe] pbx.c:     -- Executing [[email protected]:1] Set("SIP/voipms-00004324", "__FROM_DID=314NXXXXX0") in new stack
    [Dec  6 16:40:49] VERBOSE[22272][C-00001f01] pbx.c:     -- Executing [[email protected]:1] Set("SIP/voipms-0000432b", "__FROM_DID=314NXXXXX1") in new stack
    

    Look at the end of the line how it shows __FROM_DID, that is the DID as presented to your Elastix system by your incoming trunk.

    VoIP.ms sends the DID as the 10 digit number without the country code. Your PRI may show differently.



  • Thanks all , the issue is resolved now 🙂



  • How did you fix it?

    Might be helpful to a future reader.



  • @Dashrender i have added this in the DID Number Section in the Inbound Route ,
    i have 100 Lines in the PRI Line so for example my number is #23542200 to #23542299
    so what i have wrote in the DID Number was _200 and for another inbound route was _201
    and thus i found it worked fine 🙂



  • @AlyRagab said in Specific Landline from PRI Line to Specific Inbound Route:

    @Dashrender i have added this in the DID Number Section in the Inbound Route ,
    i have 100 Lines in the PRI Line so for example my number is #23542200 to #23542299
    so what i have wrote in the DID Number was _200 and for another inbound route was _201
    and thus i found it worked fine 🙂

    That is a very broad pattern though, anything ending in 200. Granted it is for a DID and you have low odds of another did ending in 200, but not impossible.

    For example: 23542200 & 23543200 both match that _200 pattern.

    You inbound DID containing a # sign is also very odd to me, but whatever.

    I tend to restrict patterns as much as possible to ensure that nothing unexpected happens with my call routing.

    In your case, I would set the pattern to _23542400 if the # sign is causing problems.



  • @JaredBusch the "#" is not regarding to the DID Section i just wrote it here as a comment ,
    and also the "_" sign matches all numbers except the endings "200" to "299"
    so it works for me fine. 🙂
    i tried writing _23542200 many times but was not working.
    i think the issue is depending on the settings of the Telecom Provider of the PRI so it may be different to another one.


Log in to reply