Ubnt ER - random quick disconnects RDP


  • Service Provider

    I have a Windows Server 2012 R2 RDS where the clients are getting disconnected at random every 5 to 10 minutes for about 1 second and then their session automatically reconnects. From what reading I have done I suspect this has something to do with the Ubiquiti Edge Router since internal clients aren't disconnected.

    I can ping the ER from the outside for hours with out a single drop and only once in a while do the ping times go in to the triple digits. The ping lags and the disconnects don't seem to be related.

    From what searching I've done it seems like it could be a problem with the MTU being too large, or the firewall trying to kill a potential DoS attack because the stream is UDP.

    Where would I check those things on the ER and does anyone have any ideas of anything else I should check?


  • Service Provider

    You are doing RDP without a VPN?


  • Service Provider

    yes. published a remote app. Users need access to that from machines that may not be company owned. Put RDPguard in place to ban IPs of multiple failed login attempts.


  • Service Provider

    @Mike-Davis said in Ubnt ER - random quick disconnects RDP:

    yes. published a remote app. Users need access to that from machines that may not be company owned. Put RDPguard in place to ban IPs of multiple failed login attempts.

    If there is a VPN, then we presume that there is no UDP traffic. Most VPNs are TCP.


Log in to reply
 

Looks like your connection to MangoLassi was lost, please wait while we try to reconnect.