ZeroTier DEB Package Failing on Linux Mint 17.3



  • Fully up to date Linux Mint 17.3 is failing to install the DEB packages for ZeroTier with the following error:

    The following packages have unmet dependencies:
     zerotier-one : Depends: libstdc++6 (>= 4.9) but 4.8.4-2ubuntu1~14.04.3 is to be installed
                    Depends: init-system-helpers (>= 1.18~) but 1.14 is to be installed
    E: Unable to correct problems, you have held broken packages.
    

    I am assuming, due to the error, that Ubuntu 14.04 is affected as well but do not have one on hand with which to test.

    @adam-ierymenko



  • @scottalanmiller said in ZeroTier DEB Package Failing on Linux Mint 17.3:

    Fully up to date Linux Mint 17.3 is failing to install the DEB packages for ZeroTier with the following error:

    The following packages have unmet dependencies:
     zerotier-one : Depends: libstdc++6 (>= 4.9) but 4.8.4-2ubuntu1~14.04.3 is to be installed
                    Depends: init-system-helpers (>= 1.18~) but 1.14 is to be installed
    E: Unable to correct problems, you have held broken packages.
    

    I am assuming, due to the error, that Ubuntu 14.04 is affected as well but do not have one on hand with which to test.

    @adam-ierymenko

    I have this problem as well.



  • Confirmed that this is working on Linux Mint 18.